summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-01-13 12:52:58 +0100
committerJonas Smedegaard <dr@jones.dk>2017-01-13 12:55:16 +0100
commit927af4e63274c77fd93913e50402823d306111f0 (patch)
tree457f2c20beaebbb71e8d90989df9956a2bc730a6 /debian/rules
parentc6ecf6bc7b64b181286ff7da5e6460a35a20ff7b (diff)
Add binary package baresip-core, and make baresip a metapackage.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 10 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index f43ea42..9d963ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,6 +47,11 @@ CDBS_BUILD_DEPENDS +=, $(patsubst %,$(comma) lib%-dev,$(core-deps))
CDBS_BUILD_DEPENDS +=, $(core-deps-extra), pkg-config
EXTRA_MODULES += $(core-mods-extra)
+CDBS_DEPENDS_baresip +=, baresip-core
+# TODO: drop these after Stretch
+CDBS_BREAKS_baresip-$1 = baresip (<= 0.5.0-1~)
+CDBS_REPLACES_baresip-$1 = baresip (<= 0.5.0-1~)
+
# Needs and module hints for module packages
ffmpeg-deps = avcodec avformat avdevice swscale x265
ffmpeg-mods = avformat avcodec h265
@@ -65,10 +70,11 @@ DEB_DH_INSTALL_ARGS_baresip-$1 = \
$$(patsubst %,usr/lib/baresip/modules/%.so,$$($1-mods) $$($1-mods-extra)) \
usr/lib/baresip/modules
# Do not install these modules as part of baresip
-DEB_DH_INSTALL_ARGS_baresip += \
+DEB_DH_INSTALL_ARGS_baresip-core += \
$$(patsubst %,-X%.so,$$($1-mods) $$($1-mods-extra))
-CDBS_SUGGESTS_baresip +=, baresip-$1
-CDBS_ENHANCES_baresip-$1 = baresip
+CDBS_RECOMMENDS_baresip +=, baresip-$1
+CDBS_SUGGESTS_baresip-core +=, baresip-$1
+CDBS_ENHANCES_baresip-$1 = baresip-core
# TODO: drop these after Stretch
CDBS_BREAKS_baresip-$1 = baresip (<= 0.5.0)
CDBS_REPLACES_baresip-$1 = baresip (<= 0.5.0)
@@ -88,7 +94,7 @@ DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(cdbs_make_curdestdir)
DEB_INSTALL_CHANGELOGS_ALL = docs/ChangeLog
DEB_INSTALL_DOCS_ALL += README.md docs/TODO
-DEB_INSTALL_EXAMPLES_baresip = docs/examples/*
+DEB_INSTALL_EXAMPLES_baresip-core = docs/examples/*
# LIBDIR for installation
LIBDIR=/usr/lib