summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-05-21 17:12:09 +0200
committerJonas Smedegaard <dr@jones.dk>2017-05-21 17:50:41 +0200
commit9cc38b4d068823354bb2dd83f6f9f0648c37095a (patch)
treeba884831507596089abe1ecd8ba5e011d9c1fda8 /debian
parent408d6cc4fa22dea91bf42f08d5af118b0be1213d (diff)
Modernize cdbs: Do copyright-check in maintainer script (not during build).
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/copyright-check27
-rwxr-xr-xdebian/rules4
2 files changed, 27 insertions, 4 deletions
diff --git a/debian/copyright-check b/debian/copyright-check
new file mode 100755
index 0000000..1be0f99
--- /dev/null
+++ b/debian/copyright-check
@@ -0,0 +1,27 @@
+#!/bin/sh
+# Copyright © 2016-2017 Jonas Smedegaard <dr@jones.dk>
+# Description: helper script to update copyright_hints
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -eu
+
+# Ignore wav files
+DEB_COPYRIGHT_CHECK_IGNORE_EXTS = wav
+
+make -f /usr/share/cdbs/1/rules/utils.mk pre-build || true
+make -f /usr/share/cdbs/1/rules/utils.mk clean DEB_COPYRIGHT_CHECK_STRICT=1
+
+# unconditionally merge changes - safe to do with git-tracked package
+[ ! -f debian/copyright_newhints ] || mv -f debian/copyright_newhints debian/copyright_hints
diff --git a/debian/rules b/debian/rules
index 99f453a..1d51555 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,6 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/makefile.mk
include /usr/share/cdbs/1/rules/debhelper.mk
@@ -31,9 +30,6 @@ debian/control::
endif
ARCHS_directfb := $(shell cat debian/ARCHS_directfb)
-# Ignore wav files
-DEB_COPYRIGHT_CHECK_IGNORE_EXTS = wav
-
# Needs and module hints for core package
core-deps = asound2 codec2 directfb jack gsm1 opus opencore-amrnb
core-deps += opencore-amrwb png re rem sdl2 sndfile1 sndio spandsp