summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2014-11-15 21:44:00 +0100
committerAlfred E. Heggestad <aeh@db.org>2014-11-15 21:44:00 +0100
commit0edf1df8783b8b8d407f972666a7108c2bbee220 (patch)
tree36228d82337dc09464f483e47ba08fa12e759bc4 /mk/modules.mk
parent5510f077f6e79ff7cc5c3581036773f5f98a9c16 (diff)
uuid: generate UUID internally in module
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index ae1d12a..aad0690 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -38,7 +38,6 @@
# USE_SRTP Secure RTP module using libre
# USE_STDIO stdio input driver
# USE_SYSLOG Syslog module
-# USE_UUID UUID module
# USE_V4L Video4Linux module
# USE_V4L2 Video4Linux2 module
# USE_WINWAVE Windows audio driver
@@ -154,7 +153,6 @@ USE_LIBSRTP := $(shell [ -f $(SYSROOT)/include/srtp/srtp.h ] || \
USE_SYSLOG := $(shell [ -f $(SYSROOT)/include/syslog.h ] || \
[ -f $(SYSROOT_ALT)/include/syslog.h ] || \
[ -f $(SYSROOT)/local/include/syslog.h ] && echo "yes")
-USE_UUID := $(shell [ -f $(SYSROOT)/include/uuid/uuid.h ] && echo "yes")
USE_V4L := $(shell [ -f $(SYSROOT)/include/libv4l1.h ] || \
[ -f $(SYSROOT)/local/include/libv4l1.h ] \
&& echo "yes")
@@ -221,6 +219,8 @@ MODULES += stun turn ice natbd auloop presence
MODULES += menu contact vumeter mwi account natpmp httpd
MODULES += selftest
MODULES += srtp
+MODULES += uuid
+
ifneq ($(HAVE_PTHREAD),)
MODULES += aubridge
endif
@@ -353,9 +353,6 @@ endif
ifneq ($(USE_SYSLOG),)
MODULES += syslog
endif
-ifneq ($(USE_UUID),)
-MODULES += uuid
-endif
ifneq ($(USE_V4L),)
MODULES += v4l
endif