summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2014-04-21 14:23:50 +0200
committerAlfred E. Heggestad <aeh@db.org>2014-04-21 14:23:50 +0200
commit397f660e1461168f2edaa9bd519bf9c794a4c18f (patch)
treea75320d1a71fc057f70a5aaa20542cedddbeab68 /mk/modules.mk
parentb83e63200be7d287311b5432122cc116b3778669 (diff)
modules: add USE_AVCAPTURE and try to detect it
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 90c877c..339391b 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -7,6 +7,7 @@
#
# USE_ALSA ALSA audio driver
# USE_AMR Adaptive Multi-Rate (AMR) audio codec
+# USE_AVCAPTURE AVFoundation video capture for OSX/iOS
# USE_BV32 BroadVoice32 Wideband Audio codec
# USE_CAIRO Cairo module
# USE_CONS Console input driver
@@ -64,6 +65,7 @@ USE_AMR := $(shell [ -d $(SYSROOT)/include/opencore-amrnb ] || \
USE_BV32 := $(shell [ -f $(SYSROOT)/include/bv32/bv32.h ] || \
[ -f $(SYSROOT)/local/include/bv32/bv32.h ] && echo "yes")
USE_CAIRO := $(shell [ -f $(SYSROOT)/include/cairo/cairo.h ] || \
+ [ -f $(SYSROOT)/local/include/cairo/cairo.h ] || \
[ -f $(SYSROOT_ALT)/include/cairo/cairo.h ] && echo "yes")
USE_DTLS := $(shell [ -f $(SYSROOT)/include/openssl/dtls1.h ] || \
[ -f $(SYSROOT)/local/include/openssl/dtls1.h ] || \
@@ -98,6 +100,7 @@ USE_ILBC := $(shell [ -f $(SYSROOT)/include/iLBC_define.h ] || \
USE_ISAC := $(shell [ -f $(SYSROOT)/include/isac.h ] || \
[ -f $(SYSROOT)/local/include/isac.h ] && echo "yes")
USE_MPG123 := $(shell [ -f $(SYSROOT)/include/mpg123.h ] || \
+ [ -f $(SYSROOT)/local/include/mpg123.h ] || \
[ -f $(SYSROOT_ALT)/include/mpg123.h ] && echo "yes")
USE_OPUS := $(shell [ -f $(SYSROOT)/include/opus/opus.h ] || \
[ -f $(SYSROOT_ALT)/include/opus/opus.h ] || \
@@ -186,7 +189,17 @@ endif
endif
+
+USE_AVFOUNDATION := \
+ $(shell [ -d /System/Library/Frameworks/AVFoundation.framework ] \
+ && echo "yes")
+
+ifneq ($(USE_AVFOUNDATION),)
+USE_AVCAPTURE := yes
+else
USE_QTCAPTURE := yes
+endif
+
endif
ifeq ($(OS),linux)
@@ -223,6 +236,9 @@ endif
ifneq ($(USE_AMR),)
MODULES += amr
endif
+ifneq ($(USE_AVCAPTURE),)
+MODULES += avcapture
+endif
ifneq ($(USE_BV32),)
MODULES += bv32
endif