summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
authorAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-02-12 12:15:15 +0100
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-02-12 12:15:15 +0100
commit39ff942fa874ff0d698d3ac938a6c8c741afb107 (patch)
tree1e496680441571582f57a945ef3f191cc3ad255b /mk/modules.mk
parent8ab125828d61fbdaeba53005973c378501fd6404 (diff)
libsrtp is deprecated, use srtp instead
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 12c4888..1aa2166 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -30,7 +30,6 @@
# USE_ILBC iLBC audio codec
# USE_ISAC iSAC audio codec
# USE_L16 L16 audio codec
-# USE_LIBSRTP Secure RTP module using libsrtp
# USE_MPA MPA audo codec
# USE_MPG123 Use mpg123
# USE_OPUS Opus audio codec
@@ -179,9 +178,6 @@ USE_SPEEX_PP := $(shell [ -f $(SYSROOT)/include/speex_preprocess.h ] || \
[ -f $(SYSROOT)/local/include/speex/speex_preprocess.h ] || \
[ -f $(SYSROOT_ALT)/include/speex/speex_preprocess.h ] || \
[ -f $(SYSROOT)/include/speex/speex_preprocess.h ] && echo "yes")
-USE_LIBSRTP := $(shell [ -f $(SYSROOT)/include/srtp/srtp.h ] || \
- [ -f $(SYSROOT_ALT)/include/srtp/srtp.h ] || \
- [ -f $(SYSROOT)/local/include/srtp/srtp.h ] && echo "yes")
USE_SYSLOG := $(shell [ -f $(SYSROOT)/include/syslog.h ] || \
[ -f $(SYSROOT_ALT)/include/syslog.h ] || \
[ -f $(SYSROOT)/local/include/syslog.h ] && echo "yes")
@@ -405,9 +401,6 @@ endif
ifneq ($(USE_SPEEX_PP),)
MODULES += speex_pp
endif
-ifneq ($(USE_LIBSRTP),)
-MODULES += libsrtp
-endif
ifneq ($(USE_STDIO),)
MODULES += stdio
endif