summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorJonathan Sieber <mail@strfry.org>2017-09-20 19:05:16 +0200
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-09-20 19:05:16 +0200
commit27ebca8548c3fbb8809d85a25262200f79d82448 (patch)
treeb402a0b630c4cc066df9209935f8e4a4bb18fce9 /mk
parent4ba1cfe60b62fb96d4de213cea3992846becf543 (diff)
Local Discovery through Avahi/ZeroConf module (#293)
* Avahi Service Announce and Discovery * Replace all instances of error() with warning() to work around #295 * avahi: Fix IPv4/v6 support, and a few nitpicks * avahi: Advertise non-standard ports
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index c5e02f0..20ff07a 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -81,6 +81,7 @@ USE_AVFORMAT := $(shell [ -f $(SYSROOT)/include/libavformat/avformat.h ] || \
[ -f $(SYSROOT)/local/include/libavformat/avformat.h ] || \
[ -f $(SYSROOT)/include/$(MACHINE)/libavformat/avformat.h ] || \
[ -f $(SYSROOT_ALT)/include/libavformat/avformat.h ] && echo "yes")
+USE_AVAHI := $(shell pkg-config --exists avahi-client && echo "yes")
USE_BV32 := $(shell [ -f $(SYSROOT)/include/bv32/bv32.h ] || \
[ -f $(SYSROOT)/local/include/bv32/bv32.h ] && echo "yes")
USE_CAIRO := $(shell [ -f $(SYSROOT)/include/cairo/cairo.h ] || \
@@ -300,6 +301,9 @@ MODULES += avcodec
ifneq ($(USE_AVFORMAT),)
MODULES += avformat
endif
+ifneq ($(USE_AVAHI),)
+MODULES += avahi
+endif
endif
ifneq ($(USE_BV32),)
MODULES += bv32