summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff <czarkoff@gmail.com>2014-04-14 13:32:38 +0200
committerDmitrij D. Czarkoff <czarkoff@gmail.com>2014-04-14 13:32:38 +0200
commit65e8347a4e50d8b89073b6c9540cf23d494f7331 (patch)
tree99b75c2900fbc88a7427850532b216168c93a73c /mk
parent907939540035984a345a754f0ff4884d07d6bf0b (diff)
v4l2: add format negotiation and OpenBSD support
Changes are: * libv4l2 is not required for proper operation any more (it is still desirable, as it guarantees that librem-supported format will be available); * v4l2 module now iterates through the list of available formats and settles on first one supported by librem; * if libv4l2 is present, baresip will try to use native format and fall back to emulated one only if no usable combination found.
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 3c96156..90c877c 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -154,9 +154,13 @@ USE_UUID := $(shell [ -f $(SYSROOT)/include/uuid/uuid.h ] && echo "yes")
USE_V4L := $(shell [ -f $(SYSROOT)/include/libv4l1.h ] || \
[ -f $(SYSROOT)/local/include/libv4l1.h ] \
&& echo "yes")
-USE_V4L2 := $(shell [ -f $(SYSROOT)/include/libv4l2.h ] || \
+HAVE_LIBV4L2 := $(shell [ -f $(SYSROOT)/include/libv4l2.h ] || \
[ -f $(SYSROOT)/local/include/libv4l2.h ] \
&& echo "yes")
+USE_V4L2 := $(shell [ -f $(SYSROOT)/include/linux/videodev2.h ] || \
+ [ -f $(SYSROOT)/local/include/linux/videodev2.h ] || \
+ [ -f $(SYSROOT)/include/sys/videoio.h ] \
+ && echo "yes")
USE_X11 := $(shell [ -f $(SYSROOT)/include/X11/Xlib.h ] || \
[ -f $(SYSROOT)/local/include/X11/Xlib.h ] || \
[ -f $(SYSROOT_ALT)/include/X11/Xlib.h ] && echo "yes")