summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorCharles Lehner <cel@celehner.com>2015-07-05 13:55:32 -0400
committerCharles Lehner <cel@celehner.com>2015-07-05 15:11:49 -0400
commit9ef06aa7fb2a236e6a41cd9c5cb34c73a4a7a378 (patch)
tree3ff77340f4ef6e58d18b52d81d8d8c18ce71a2ce /mk
parent5c6821f742c2b3751fff5574bba3666826d723f1 (diff)
Add gtk module
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index f1ed497..0bf72a9 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -43,6 +43,7 @@
# USE_V4L2 Video4Linux2 module
# USE_WINWAVE Windows audio driver
# USE_X11 X11 video output
+# USE_GTK GTK+ user interface
#
@@ -171,6 +172,9 @@ USE_VPX := $(shell [ -f $(SYSROOT)/include/vpx/vp8.h ] \
|| [ -f $(SYSROOT)/local/include/vpx/vp8.h ] \
|| [ -f $(SYSROOT_ALT)/include/vpx/vp8.h ] \
&& echo "yes")
+USE_GTK := $(shell [ -f $(SYSROOT)/include/gtk-2.0/gtk/gtk.h ] || \
+ [ -f $(SYSROOT)/local/include/gtk-2.0/gtk/gtk.h ] || \
+ [ -f $(SYSROOT_ALT)/include/gtk-2.0/gtk/gtk.h ] && echo "yes")
endif
# Platform specific modules
@@ -357,3 +361,6 @@ endif
ifneq ($(USE_X11),)
MODULES += x11 x11grab
endif
+ifneq ($(USE_GTK),)
+MODULES += gtk
+endif