summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2015-09-26 16:06:01 +0200
committerAlfred E. Heggestad <aeh@db.org>2015-09-26 16:06:01 +0200
commitca226753e03c1773dab1899cb27fa3e94b7b6581 (patch)
treea1460865620bc2b7c94cd9b53adb0cbe242e05a5 /mk
parentfda46a5e629e3a9c348e73e3ef8ca8f33acf762f (diff)
better detection of avcodec/avformat
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index ac16662..3fc85b4 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -69,9 +69,11 @@ USE_AMR := $(shell [ -d $(SYSROOT)/include/opencore-amrnb ] || \
[ -d $(SYSROOT)/include/amrnb ] && echo "yes")
USE_AVCODEC := $(shell [ -f $(SYSROOT)/include/libavcodec/avcodec.h ] || \
[ -f $(SYSROOT)/local/include/libavcodec/avcodec.h ] || \
+ [ -f $(SYSROOT)/include/$(MACHINE)/libavcodec/avcodec.h ] || \
[ -f $(SYSROOT_ALT)/include/libavcodec/avcodec.h ] && echo "yes")
USE_AVFORMAT := $(shell [ -f $(SYSROOT)/include/libavformat/avformat.h ] || \
[ -f $(SYSROOT)/local/include/libavformat/avformat.h ] || \
+ [ -f $(SYSROOT)/include/$(MACHINE)/libavformat/avformat.h ] || \
[ -f $(SYSROOT_ALT)/include/libavformat/avformat.h ] && echo "yes")
USE_BV32 := $(shell [ -f $(SYSROOT)/include/bv32/bv32.h ] || \
[ -f $(SYSROOT)/local/include/bv32/bv32.h ] && echo "yes")