summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
authortonylangley <tony@langleyau.net>2017-04-14 18:39:48 +1000
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-04-14 11:39:48 +0300
commite4cb662923168664215f330298676bcd64190f33 (patch)
treedc0adf9b02d46a8eff63cc6f43eb160eee353859 /mk
parente1b3a44a3a9a0dc83a14b8dad493ba79d4ba038f (diff)
Update to include JACK Audio Driver (#233)
This appeared to be missing. Also updated the copyright date to 2017.
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 46f5f37..c5e02f0 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -1,7 +1,7 @@
#
# modules.mk
#
-# Copyright (C) 2010 - 2016 Creytiv.com
+# Copyright (C) 2010 - 2017 Creytiv.com
#
# External libraries:
#
@@ -29,6 +29,7 @@
# USE_H265 H.265 video codec
# USE_ILBC iLBC audio codec
# USE_ISAC iSAC audio codec
+# USE_JACK JACK Audio Connection Kit audio driver
# USE_L16 L16 audio codec
# USE_MPA MPA audo codec
# USE_MPG123 Use mpg123
@@ -123,6 +124,8 @@ USE_ILBC := $(shell [ -f $(SYSROOT)/include/iLBC_define.h ] || \
[ -f $(SYSROOT)/local/include/iLBC_define.h ] && echo "yes")
USE_ISAC := $(shell [ -f $(SYSROOT)/include/isac.h ] || \
[ -f $(SYSROOT)/local/include/isac.h ] && echo "yes")
+USE_JACK := $(shell [ -f $(SYSROOT)/include/jack/jack.h ] || \
+ [ -f $(SYSROOT)/local/include/jack/jack.h ] && echo "yes")
USE_MPG123 := $(shell [ -f $(SYSROOT)/include/mpg123.h ] || \
[ -f $(SYSROOT)/local/include/mpg123.h ] || \
[ -f $(SYSROOT_ALT)/include/mpg123.h ] && echo "yes")
@@ -363,6 +366,9 @@ endif
ifneq ($(USE_ISAC),)
MODULES += isac
endif
+ifneq ($(USE_JACK),)
+MODULES += jack
+endif
ifneq ($(USE_L16),)
MODULES += l16
endif