summaryrefslogtreecommitdiff
path: root/modules/avcodec
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2014-11-22 21:09:26 +0100
committerAlfred E. Heggestad <aeh@db.org>2014-11-22 21:09:26 +0100
commit33db275dbe5846edc99cd6c0d6a1747cf7014766 (patch)
treecbe513c370d88fa5ce114defce6d13adfa8ab2c6 /modules/avcodec
parent918fb79b58c07c64731baf574b3bec2d57e96a1f (diff)
improve FFmpeg/libav module detection
- remove FFmpeg keyword, as both FFmpeg and libav is supported - avcodec.so need libavcodec - avformat.so needs libavformat and others - also made the "quicktime.so" module deprecated
Diffstat (limited to 'modules/avcodec')
-rw-r--r--modules/avcodec/avcodec.c4
-rw-r--r--modules/avcodec/avcodec.h2
-rw-r--r--modules/avcodec/decode.c2
-rw-r--r--modules/avcodec/encode.c4
-rw-r--r--modules/avcodec/module.mk2
5 files changed, 7 insertions, 7 deletions
diff --git a/modules/avcodec/avcodec.c b/modules/avcodec/avcodec.c
index 1fb1415..2b634df 100644
--- a/modules/avcodec/avcodec.c
+++ b/modules/avcodec/avcodec.c
@@ -1,5 +1,5 @@
/**
- * @file avcodec.c Video codecs using FFmpeg libavcodec
+ * @file avcodec.c Video codecs using libavcodec
*
* Copyright (C) 2010 Creytiv.com
*/
@@ -136,7 +136,7 @@ static int module_init(void)
#ifdef USE_X264
debug("avcodec: x264 build %d\n", X264_BUILD);
#else
- debug("avcodec: using FFmpeg H.264 encoder\n");
+ debug("avcodec: using libavcodec H.264 encoder\n");
#endif
#if LIBAVCODEC_VERSION_INT < ((53<<16)+(10<<8)+0)
diff --git a/modules/avcodec/avcodec.h b/modules/avcodec/avcodec.h
index 1d91b27..0b275f3 100644
--- a/modules/avcodec/avcodec.h
+++ b/modules/avcodec/avcodec.h
@@ -1,5 +1,5 @@
/**
- * @file avcodec.h Video codecs using FFmpeg libavcodec -- internal API
+ * @file avcodec.h Video codecs using libavcodec -- internal API
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/avcodec/decode.c b/modules/avcodec/decode.c
index 289d5a8..06d43b0 100644
--- a/modules/avcodec/decode.c
+++ b/modules/avcodec/decode.c
@@ -1,5 +1,5 @@
/**
- * @file avcodec/decode.c Video codecs using FFmpeg libavcodec -- decoder
+ * @file avcodec/decode.c Video codecs using libavcodec -- decoder
*
* Copyright (C) 2010 - 2013 Creytiv.com
*/
diff --git a/modules/avcodec/encode.c b/modules/avcodec/encode.c
index 4742686..db4ae3b 100644
--- a/modules/avcodec/encode.c
+++ b/modules/avcodec/encode.c
@@ -1,5 +1,5 @@
/**
- * @file avcodec/encode.c Video codecs using FFmpeg libavcodec -- encoder
+ * @file avcodec/encode.c Video codecs using libavcodec -- encoder
*
* Copyright (C) 2010 - 2013 Creytiv.com
*/
@@ -173,7 +173,7 @@ static int open_encoder(struct videnc_state *st,
st->ctx->time_base.num = 1;
st->ctx->time_base.den = prm->fps;
- /* params to avoid ffmpeg/x264 default preset error */
+ /* params to avoid libavcodec/x264 default preset error */
if (st->codec_id == AV_CODEC_ID_H264) {
st->ctx->me_method = ME_UMH;
st->ctx->me_range = 16;
diff --git a/modules/avcodec/module.mk b/modules/avcodec/module.mk
index b209a57..acff21b 100644
--- a/modules/avcodec/module.mk
+++ b/modules/avcodec/module.mk
@@ -11,7 +11,7 @@ USE_X264 := $(shell [ -f $(SYSROOT)/include/x264.h ] || \
MOD := avcodec
$(MOD)_SRCS += avcodec.c h263.c h264.c encode.c decode.c
$(MOD)_LFLAGS += -lavcodec -lavutil
-CFLAGS += -I/usr/include/ffmpeg
+CFLAGS += -DUSE_AVCODEC
ifneq ($(USE_X264),)
CFLAGS += -DUSE_X264
$(MOD)_LFLAGS += -lx264