summaryrefslogtreecommitdiff
path: root/modules/gst1
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff <czarkoff@gmail.com>2015-10-10 20:30:05 +0200
committerDmitrij D. Czarkoff <czarkoff@gmail.com>2015-10-10 20:30:05 +0200
commit3e4957cbf3342fc90fb5578125cb492a12e84cd4 (patch)
treed92befab6ec3c2637d30e7aff46389c7eee16cad /modules/gst1
parent54efc65c09e233a92050e6150ceac3cc629c48c6 (diff)
Get rid of VAR += `pkg-config ...` idiom
Output of pkg-config shouldn't change during build, so it is sufficient to run it once per check.
Diffstat (limited to 'modules/gst1')
-rw-r--r--modules/gst1/module.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/gst1/module.mk b/modules/gst1/module.mk
index e79a9b7..e9fad39 100644
--- a/modules/gst1/module.mk
+++ b/modules/gst1/module.mk
@@ -6,8 +6,8 @@
MOD := gst1
$(MOD)_SRCS += gst.c
-$(MOD)_LFLAGS += `pkg-config --libs gstreamer-1.0`
-$(MOD)_CFLAGS += `pkg-config --cflags gstreamer-1.0`
+$(MOD)_LFLAGS != pkg-config --libs gstreamer-1.0
+$(MOD)_CFLAGS != pkg-config --cflags gstreamer-1.0
$(MOD)_CFLAGS += -Wno-cast-align
include mk/mod.mk