summaryrefslogtreecommitdiff
path: root/modules/gst1
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2015-08-01 19:05:55 +0200
committerAlfred E. Heggestad <aeh@db.org>2015-08-01 19:05:55 +0200
commit64fe62e5b09fb2997d64936fcd52441df3447109 (patch)
tree5ffa3f97e98e9b872ca62afe7008cc953df2d749 /modules/gst1
parent5afea9730d64aacf3adcb822b34bbc810ed4dedb (diff)
gst: update doxygen headers
Diffstat (limited to 'modules/gst1')
-rw-r--r--modules/gst1/dump.c65
-rw-r--r--modules/gst1/gst.c11
-rw-r--r--modules/gst1/gst.h4
-rw-r--r--modules/gst1/module.mk2
4 files changed, 6 insertions, 76 deletions
diff --git a/modules/gst1/dump.c b/modules/gst1/dump.c
deleted file mode 100644
index d1f9447..0000000
--- a/modules/gst1/dump.c
+++ /dev/null
@@ -1,65 +0,0 @@
-/**
- * @file dump.c Gstreamer playbin pipeline - dump utilities
- *
- * Copyright (C) 2010 Creytiv.com
- */
-#include <re.h>
-#include <baresip.h>
-#include <gst/gst.h>
-#include "gst.h"
-
-
-void gst1_dump_props(GstElement *g)
-{
- uint64_t u64;
- gchar *strval;
- double volume;
- int n;
-
- debug("Gst properties:\n");
-
- g_object_get(g, "delay", &u64, NULL);
- debug(" delay: %lu ns\n", u64);
-
- g_object_get(g, "uri", &strval, NULL);
- debug(" uri: %s\n", strval);
- g_free(strval);
-
- g_object_get(g, "suburi", &strval, NULL);
- debug(" suburi: %s\n", strval);
- g_free(strval);
-
- g_object_get(g, "queue-size", &u64, NULL);
- debug(" queue-size: %lu ns\n", u64);
-
- g_object_get(g, "queue-threshold", &u64, NULL);
- debug(" queue-threshold: %lu ns\n", u64);
-
- g_object_get(g, "nstreams", &n, NULL);
- debug(" nstreams: %d\n", n);
-
- g_object_get(g, "volume", &volume, NULL);
- debug(" Volume: %f\n", volume);
-}
-
-
-void gst1_dump_caps(const GstCaps *caps)
-{
- GstStructure *s;
- int rate, channels, width;
-
- if (!caps)
- return;
-
- if (!gst_caps_get_size(caps))
- return;
-
- s = gst_caps_get_structure(caps, 0);
-
- gst_structure_get_int(s, "rate", &rate);
- gst_structure_get_int(s, "channels", &channels);
- gst_structure_get_int(s, "width", &width);
-
- info("gst: caps dump: %d Hz, %d channels, width=%d\n",
- rate, channels, width);
-}
diff --git a/modules/gst1/gst.c b/modules/gst1/gst.c
index c9ac920..bae477d 100644
--- a/modules/gst1/gst.c
+++ b/modules/gst1/gst.c
@@ -1,5 +1,5 @@
/**
- * @file gst.c Gstreamer playbin pipeline
+ * @file gst1/gst.c Gstreamer 1.0 playbin pipeline
*
* Copyright (C) 2010 - 2015 Creytiv.com
*/
@@ -16,11 +16,11 @@
/**
- * @defgroup gst gst
+ * @defgroup gst1 gst1
*
- * Audio source module using gstreamer as input
+ * Audio source module using gstreamer 1.0 as input
*
- * The module 'gst' is using the Gstreamer framework to play external
+ * The module 'gst1' is using the Gstreamer framework to play external
* media and provide this as an internal audio source.
*
* Example config:
@@ -261,9 +261,6 @@ static void set_caps(struct ausrc_st *st)
"width", G_TYPE_INT, 16,
"signed", G_TYPE_BOOLEAN,true,
NULL);
-#if 1
- gst1_dump_caps(caps);
-#endif
g_object_set(G_OBJECT(st->capsfilt), "caps", caps, NULL);
}
diff --git a/modules/gst1/gst.h b/modules/gst1/gst.h
index 373bed7..830ee34 100644
--- a/modules/gst1/gst.h
+++ b/modules/gst1/gst.h
@@ -1,9 +1,7 @@
/**
- * @file gst.h Gstreamer playbin pipeline -- internal interface
+ * @file gst1/gst.h Gstreamer playbin pipeline -- internal interface
*
* Copyright (C) 2010 Creytiv.com
*/
-void gst1_dump_props(GstElement *g);
-void gst1_dump_caps(const GstCaps *caps);
diff --git a/modules/gst1/module.mk b/modules/gst1/module.mk
index 5e600d2..bd66452 100644
--- a/modules/gst1/module.mk
+++ b/modules/gst1/module.mk
@@ -5,7 +5,7 @@
#
MOD := gst1
-$(MOD)_SRCS += gst.c dump.c
+$(MOD)_SRCS += gst.c
$(MOD)_LFLAGS += `pkg-config --libs gstreamer-1.0`
$(MOD)_CFLAGS += `pkg-config --cflags gstreamer-1.0`