summaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2016-06-04 22:15:30 +0200
committerAlfred E. Heggestad <aeh@db.org>2016-06-04 22:15:30 +0200
commit346aaad2b057f823b7181e7b6711badd2554e5c2 (patch)
treee96076ad537c1a078acb3f9584fb2df513906805 /modules
parentb062f43d7ec08324593cd6f1bdfed98ebeeafdc9 (diff)
vp8: rename vpx.so module to vp8.so
Diffstat (limited to 'modules')
-rw-r--r--modules/vp8/decode.c (renamed from modules/vpx/decode.c)2
-rw-r--r--modules/vp8/encode.c (renamed from modules/vpx/encode.c)2
-rw-r--r--modules/vp8/module.mk (renamed from modules/vpx/module.mk)4
-rw-r--r--modules/vp8/sdp.c (renamed from modules/vpx/sdp.c)2
-rw-r--r--modules/vp8/vp8.c (renamed from modules/vpx/vpx.c)25
-rw-r--r--modules/vp8/vp8.h (renamed from modules/vpx/vp8.h)0
6 files changed, 15 insertions, 20 deletions
diff --git a/modules/vpx/decode.c b/modules/vp8/decode.c
index f441619..1722eb6 100644
--- a/modules/vpx/decode.c
+++ b/modules/vp8/decode.c
@@ -1,5 +1,5 @@
/**
- * @file vpx/decode.c VP8 Decode
+ * @file vp8/decode.c VP8 Decode
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/vpx/encode.c b/modules/vp8/encode.c
index 0106c0a..8b9e91b 100644
--- a/modules/vpx/encode.c
+++ b/modules/vp8/encode.c
@@ -1,5 +1,5 @@
/**
- * @file vpx/encode.c VP8 Encode
+ * @file vp8/encode.c VP8 Encode
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/vpx/module.mk b/modules/vp8/module.mk
index bcd8c9d..4142af5 100644
--- a/modules/vpx/module.mk
+++ b/modules/vp8/module.mk
@@ -4,10 +4,10 @@
# Copyright (C) 2010 Creytiv.com
#
-MOD := vpx
+MOD := vp8
$(MOD)_SRCS += decode.c
$(MOD)_SRCS += encode.c
-$(MOD)_SRCS += vpx.c
+$(MOD)_SRCS += vp8.c
$(MOD)_SRCS += sdp.c
$(MOD)_LFLAGS += -lvpx
diff --git a/modules/vpx/sdp.c b/modules/vp8/sdp.c
index 21ed9d6..8d2ecca 100644
--- a/modules/vpx/sdp.c
+++ b/modules/vp8/sdp.c
@@ -1,5 +1,5 @@
/**
- * @file vpx/sdp.c VP8 SDP Functions
+ * @file vp8/sdp.c VP8 SDP Functions
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/vpx/vpx.c b/modules/vp8/vp8.c
index 0c17caa..acaad12 100644
--- a/modules/vpx/vpx.c
+++ b/modules/vp8/vp8.c
@@ -1,23 +1,16 @@
/**
- * @file vpx.c VP8 video codec
+ * @file vp8.c VP8 Video Codec
*
* Copyright (C) 2010 Creytiv.com
*/
-#include <string.h>
#include <re.h>
#include <rem.h>
#include <baresip.h>
-#define VPX_CODEC_DISABLE_COMPAT 1
-#define VPX_DISABLE_CTRL_TYPECHECKS 1
-#include <vpx/vpx_encoder.h>
-#include <vpx/vpx_decoder.h>
-#include <vpx/vp8cx.h>
-#include <vpx/vp8dx.h>
#include "vp8.h"
/**
- * @defgroup vpx vpx
+ * @defgroup vp8 vp8
*
* The VP8 video codec
*
@@ -32,7 +25,7 @@
*/
-static struct vp8_vidcodec vpx = {
+static struct vp8_vidcodec vp8 = {
.vc = {
.name = "VP8",
.encupdh = vp8_encode_update,
@@ -41,26 +34,28 @@ static struct vp8_vidcodec vpx = {
.dech = vp8_decode,
.fmtp_ench = vp8_fmtp_enc,
},
- .max_fs = 3600
+ .max_fs = 3600,
};
static int module_init(void)
{
- vidcodec_register((struct vidcodec *)&vpx);
+ vidcodec_register((struct vidcodec *)&vp8);
+
return 0;
}
static int module_close(void)
{
- vidcodec_unregister((struct vidcodec *)&vpx);
+ vidcodec_unregister((struct vidcodec *)&vp8);
+
return 0;
}
-EXPORT_SYM const struct mod_export DECL_EXPORTS(vpx) = {
- "vpx",
+EXPORT_SYM const struct mod_export DECL_EXPORTS(vp8) = {
+ "vp8",
"codec",
module_init,
module_close
diff --git a/modules/vpx/vp8.h b/modules/vp8/vp8.h
index 934e3ee..934e3ee 100644
--- a/modules/vpx/vp8.h
+++ b/modules/vp8/vp8.h