summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mk/modules.mk3
-rw-r--r--modules/vp9/vp9.c3
2 files changed, 5 insertions, 1 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 86aa2b9..8f4f288 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -414,7 +414,8 @@ ifneq ($(USE_V4L2),)
MODULES += v4l2 v4l2_codec
endif
ifneq ($(USE_VPX),)
-MODULES += vp8 vp9
+MODULES += vp8
+MODULES += $(shell pkg-config 'vpx >= 1.3.0' && echo "vp9")
endif
ifneq ($(USE_WINWAVE),)
MODULES += winwave
diff --git a/modules/vp9/vp9.c b/modules/vp9/vp9.c
index 852a19a..676d5c5 100644
--- a/modules/vp9/vp9.c
+++ b/modules/vp9/vp9.c
@@ -18,6 +18,9 @@
* This module implements the VP9 video codec that is compatible
* with the WebRTC standard.
*
+ * Libvpx version 1.3.0 or later is required.
+ *
+ *
* References:
*
* http://www.webmproject.org/