summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog49
-rw-r--r--docs/README2
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
-rw-r--r--src/main.c2
8 files changed, 61 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index efb6c7a..89e3fbd 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.16
+VERSION := 0.4.17
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 8134488..3b645a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.17) unstable; urgency=low
+
+ * version 0.4.17
+
+ -- Alfred E. Heggestad <aeh@db.org> Sun, 17 Jan 2016 12:00:00 +0100
+
baresip (0.4.16) unstable; urgency=low
* version 0.4.16
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 1abbe85..fe13478 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,52 @@
+2016-01-17 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.17
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.4.17
+ * NOTE: Requires libre v0.4.14 or later
+ Requires librem v0.4.7 or later
+
+ * new modules:
+ - echo Echo server module
+ - jack JACK Audio Connection Kit audio-driver
+
+ * baresip-core:
+ - config: keep config object in memory
+ - ua: moved playing of ringtones out of core, to "menu" module
+ (let's keep the core nice and slim..)
+ - ui: added ui_password_prompt()
+
+ * selftest:
+ - silence debug/info log by default, only print warnings
+ (use -v to see verbose logging)
+
+ * Modules:
+
+ * alsa: added config option to specify the sample format
+ "alsa_sample_format {s16,float,s24_3le}"
+ thanks to Ola Palm for valuable feedback
+
+ * audiounit: fix recording on OSX (thanks Sebastian Reimers)
+ print hardware samplerate in debug mode
+
+ * auloop: add support for 44100 Hz samplerate
+
+ * daala: update to latest libdaala API (thanks Dmitrij D. Czarkoff)
+
+ * echo: new module which implements a simple Echo-server, to
+ be used in combination with the aubridge.so module.
+ contributed by Sebastian Reimers
+
+ * gtk: fixes to support C89 compiler (thanks Dmitrij D. Czarkoff)
+
+ * jack: new module which implements audio-driver for JACK
+
+ * menu: playing of ringtones moved here, from ua.c
+
+ * sndio: fix crash when device open fails (thanks Dmitrij D. Czarkoff)
+
+
2015-12-01 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.16
diff --git a/docs/README b/docs/README
index bb9511e..fd38140 100644
--- a/docs/README
+++ b/docs/README
@@ -2,7 +2,7 @@ README
------
Baresip is a portable and modular SIP User-Agent with audio and video support
-Copyright (c) 2010 - 2015 Creytiv.com
+Copyright (c) 2010 - 2016 Creytiv.com
Distributed under BSD license
diff --git a/include/baresip.h b/include/baresip.h
index d9d1013..722c97c 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.16"
+#define BARESIP_VERSION "0.4.17"
/* forward declarations */
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 10be927..d0fd453 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.16
+PROJECT_NUMBER = 0.4.17
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 4603797..80a5d4f 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.16
+%define ver 0.4.17
%define rel 1
Summary: Modular SIP useragent
diff --git a/src/main.c b/src/main.c
index 1760dc7..9193053 100644
--- a/src/main.c
+++ b/src/main.c
@@ -65,7 +65,7 @@ int main(int argc, char *argv[])
int err;
(void)re_fprintf(stderr, "baresip v%s"
- " Copyright (C) 2010 - 2015"
+ " Copyright (C) 2010 - 2016"
" Alfred E. Heggestad et al.\n",
BARESIP_VERSION);