summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--modules/gst/dump.c2
-rw-r--r--modules/gst/gst.c2
-rw-r--r--modules/gst/gst.h2
-rw-r--r--modules/gst1/dump.c65
-rw-r--r--modules/gst1/gst.c11
-rw-r--r--modules/gst1/gst.h4
-rw-r--r--modules/gst1/module.mk2
-rw-r--r--modules/gst_video/gst_video.c2
-rw-r--r--modules/gst_video/gst_video.h2
-rw-r--r--modules/gst_video1/gst_video.c4
-rw-r--r--modules/gst_video1/gst_video.h2
11 files changed, 14 insertions, 84 deletions
diff --git a/modules/gst/dump.c b/modules/gst/dump.c
index 685d8f6..138b3ed 100644
--- a/modules/gst/dump.c
+++ b/modules/gst/dump.c
@@ -1,5 +1,5 @@
/**
- * @file dump.c Gstreamer playbin pipeline - dump utilities
+ * @file gst/dump.c Gstreamer playbin pipeline - dump utilities
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/gst/gst.c b/modules/gst/gst.c
index 2e846fc..2ddb4d6 100644
--- a/modules/gst/gst.c
+++ b/modules/gst/gst.c
@@ -1,5 +1,5 @@
/**
- * @file gst.c Gstreamer playbin pipeline
+ * @file gst/gst.c Gstreamer playbin pipeline
*
* Copyright (C) 2010 - 2015 Creytiv.com
*/
diff --git a/modules/gst/gst.h b/modules/gst/gst.h
index 9627188..37faac9 100644
--- a/modules/gst/gst.h
+++ b/modules/gst/gst.h
@@ -1,5 +1,5 @@
/**
- * @file gst.h Gstreamer playbin pipeline -- internal interface
+ * @file gst/gst.h Gstreamer playbin pipeline -- internal interface
*
* Copyright (C) 2010 Creytiv.com
*/
diff --git a/modules/gst1/dump.c b/modules/gst1/dump.c
deleted file mode 100644
index d1f9447..0000000
--- a/modules/gst1/dump.c
+++ /dev/null
@@ -1,65 +0,0 @@
-/**
- * @file dump.c Gstreamer playbin pipeline - dump utilities
- *
- * Copyright (C) 2010 Creytiv.com
- */
-#include <re.h>
-#include <baresip.h>
-#include <gst/gst.h>
-#include "gst.h"
-
-
-void gst1_dump_props(GstElement *g)
-{
- uint64_t u64;
- gchar *strval;
- double volume;
- int n;
-
- debug("Gst properties:\n");
-
- g_object_get(g, "delay", &u64, NULL);
- debug(" delay: %lu ns\n", u64);
-
- g_object_get(g, "uri", &strval, NULL);
- debug(" uri: %s\n", strval);
- g_free(strval);
-
- g_object_get(g, "suburi", &strval, NULL);
- debug(" suburi: %s\n", strval);
- g_free(strval);
-
- g_object_get(g, "queue-size", &u64, NULL);
- debug(" queue-size: %lu ns\n", u64);
-
- g_object_get(g, "queue-threshold", &u64, NULL);
- debug(" queue-threshold: %lu ns\n", u64);
-
- g_object_get(g, "nstreams", &n, NULL);
- debug(" nstreams: %d\n", n);
-
- g_object_get(g, "volume", &volume, NULL);
- debug(" Volume: %f\n", volume);
-}
-
-
-void gst1_dump_caps(const GstCaps *caps)
-{
- GstStructure *s;
- int rate, channels, width;
-
- if (!caps)
- return;
-
- if (!gst_caps_get_size(caps))
- return;
-
- s = gst_caps_get_structure(caps, 0);
-
- gst_structure_get_int(s, "rate", &rate);
- gst_structure_get_int(s, "channels", &channels);
- gst_structure_get_int(s, "width", &width);
-
- info("gst: caps dump: %d Hz, %d channels, width=%d\n",
- rate, channels, width);
-}
diff --git a/modules/gst1/gst.c b/modules/gst1/gst.c
index c9ac920..bae477d 100644
--- a/modules/gst1/gst.c
+++ b/modules/gst1/gst.c
@@ -1,5 +1,5 @@
/**
- * @file gst.c Gstreamer playbin pipeline
+ * @file gst1/gst.c Gstreamer 1.0 playbin pipeline
*
* Copyright (C) 2010 - 2015 Creytiv.com
*/
@@ -16,11 +16,11 @@
/**
- * @defgroup gst gst
+ * @defgroup gst1 gst1
*
- * Audio source module using gstreamer as input
+ * Audio source module using gstreamer 1.0 as input
*
- * The module 'gst' is using the Gstreamer framework to play external
+ * The module 'gst1' is using the Gstreamer framework to play external
* media and provide this as an internal audio source.
*
* Example config:
@@ -261,9 +261,6 @@ static void set_caps(struct ausrc_st *st)
"width", G_TYPE_INT, 16,
"signed", G_TYPE_BOOLEAN,true,
NULL);
-#if 1
- gst1_dump_caps(caps);
-#endif
g_object_set(G_OBJECT(st->capsfilt), "caps", caps, NULL);
}
diff --git a/modules/gst1/gst.h b/modules/gst1/gst.h
index 373bed7..830ee34 100644
--- a/modules/gst1/gst.h
+++ b/modules/gst1/gst.h
@@ -1,9 +1,7 @@
/**
- * @file gst.h Gstreamer playbin pipeline -- internal interface
+ * @file gst1/gst.h Gstreamer playbin pipeline -- internal interface
*
* Copyright (C) 2010 Creytiv.com
*/
-void gst1_dump_props(GstElement *g);
-void gst1_dump_caps(const GstCaps *caps);
diff --git a/modules/gst1/module.mk b/modules/gst1/module.mk
index 5e600d2..bd66452 100644
--- a/modules/gst1/module.mk
+++ b/modules/gst1/module.mk
@@ -5,7 +5,7 @@
#
MOD := gst1
-$(MOD)_SRCS += gst.c dump.c
+$(MOD)_SRCS += gst.c
$(MOD)_LFLAGS += `pkg-config --libs gstreamer-1.0`
$(MOD)_CFLAGS += `pkg-config --cflags gstreamer-1.0`
diff --git a/modules/gst_video/gst_video.c b/modules/gst_video/gst_video.c
index b04dbe4..b0afa06 100644
--- a/modules/gst_video/gst_video.c
+++ b/modules/gst_video/gst_video.c
@@ -1,5 +1,5 @@
/**
- * @file gst_video.c Video codecs using Gstreamer
+ * @file gst_video/gst_video.c Video codecs using Gstreamer
*
* Copyright (C) 2010 Creytiv.com
* Copyright (C) 2014 Fadeev Alexander
diff --git a/modules/gst_video/gst_video.h b/modules/gst_video/gst_video.h
index 16817e1..7c5af23 100644
--- a/modules/gst_video/gst_video.h
+++ b/modules/gst_video/gst_video.h
@@ -1,5 +1,5 @@
/**
- * @file gst_video.h Gstreamer video pipeline -- internal API
+ * @file gst_video/gst_video.h Gstreamer video pipeline -- internal API
*
* Copyright (C) 2010 - 2014 Creytiv.com
* Copyright (C) 2014 Fadeev Alexander
diff --git a/modules/gst_video1/gst_video.c b/modules/gst_video1/gst_video.c
index 56c90f5..e0a4286 100644
--- a/modules/gst_video1/gst_video.c
+++ b/modules/gst_video1/gst_video.c
@@ -1,5 +1,5 @@
/**
- * @file gst_video.c Video codecs using Gstreamer 1.0
+ * @file gst_video1/gst_video.c Video codecs using Gstreamer 1.0
*
* Copyright (C) 2010 Creytiv.com
* Copyright (C) 2014 Fadeev Alexander
@@ -13,7 +13,7 @@
/**
- * @defgroup gst_video gst_video
+ * @defgroup gst_video1 gst_video1
*
* This module implements video codecs using Gstreamer 1.0
*
diff --git a/modules/gst_video1/gst_video.h b/modules/gst_video1/gst_video.h
index 83aa1ee..6f74151 100644
--- a/modules/gst_video1/gst_video.h
+++ b/modules/gst_video1/gst_video.h
@@ -1,5 +1,5 @@
/**
- * @file gst_video.h Gstreamer video pipeline -- internal API
+ * @file gst_video1/gst_video.h Gstreamer video pipeline -- internal API
*
* Copyright (C) 2010 - 2014 Creytiv.com
* Copyright (C) 2014 Fadeev Alexander