summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog53
-rw-r--r--docs/README2
-rw-r--r--docs/TODO3
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
8 files changed, 67 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 0898bad..e3401db 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.13
+VERSION := 0.4.14
ifndef LIBRE_MK
LIBRE_MK := $(shell [ -f ../re/mk/re.mk ] && \
diff --git a/debian/changelog b/debian/changelog
index e23468c..3a2dcab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.14) unstable; urgency=low
+
+ * version 0.4.14
+
+ -- Alfred E. Heggestad <aeh@db.org> Sat, 8 Aug 2015 12:00:00 +0100
+
baresip (0.4.13) unstable; urgency=low
* version 0.4.13
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 2d295be..72c4ba5 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,56 @@
+2015-08-08 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.14
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT commit ebac23b0692de71ee4c3a436f0372013150c937f
+ * GIT tag: v0.4.14
+ * NOTE: Requires libre v0.4.13 or later
+
+ * new modules:
+ - gtk GTK+ 2.0 UI (thanks Charles E. Lehner)
+ - gst1 Gstreamer 1.0 audio module
+ - gst_video1 Gstreamer 1.0 video module (thanks Thomas Strobel)
+ - daala Experimental video-codec using Daala
+
+ * baresip-core:
+ - baresip: added -m argument to pre-load modules
+ - config: add kqueue to sample config (thanks Dmitrij D. Czarkoff)
+ - log: make code C89 compliant (thanks Victor Sergienko)
+ - module: added module_preload()
+ - ua: add CALL_EVENT_TRANSFER_FAILED
+ - ua: skip initial white space from uri (thanks Juha Heinanen)
+ - ua: ua_prev_call()
+ - videnc: move videnc_packet_h to update-handler
+
+ * build:
+ - added optional $(MOD)_CFLAGS for local module CFLAGS
+ - added project file for Visual C++ Express 2010
+ - freebsd: add include path to $(SYSROOT)/local/include
+ (thanks Hellmuth Michaelis)
+
+ * Modules:
+
+ * avcodec: make code C89 compliant (thanks Victor Sergienko)
+
+ * cons: make code C89 compliant (thanks Victor Sergienko)
+
+ * daala: new module
+
+ * dshow: updates for VC2010 (thanks Victor Sergienko)
+
+ * gst1: new module
+
+ * gst_video1: new module
+
+ * gtk: new module
+
+ * menu: fix crash when 0 UAs (thanks Hans Petter Selasky)
+ added command 'H' to hold previous call (thanks xanm)
+
+ * wincons: make code C89 compliant (thanks ggcoding)
+
+
2015-06-20 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.13
diff --git a/docs/README b/docs/README
index 2e22a84..24af38b 100644
--- a/docs/README
+++ b/docs/README
@@ -163,7 +163,9 @@ g7221 G.722.1 audio codec
g726 G.726 audio codec
gsm GSM audio codec
gst Gstreamer audio source
+gst1 Gstreamer 1.0 audio source
gst_video Gstreamer video codec
+gst_video1 Gstreamer 1.0 video codec
gtk GTK+ 2.0 UI
h265 H.265 video codec
httpd HTTP webserver UI-module
diff --git a/docs/TODO b/docs/TODO
index 88c748c..ccf92ac 100644
--- a/docs/TODO
+++ b/docs/TODO
@@ -17,10 +17,11 @@ Version v0.x.y:
avcodec-audio.so -- create a new audio-codec module that will use
audio codecs from FFmpeg libavcodec, as a supplement to existing codecs.
+ move common H.264 code to either baresip-core or librem
+
-------------------------------------------------------------------------------
BUGS:
- S605th: no DNS-server IP
sdl: crashes in virtualbox/linux
-------------------------------------------------------------------------------
diff --git a/include/baresip.h b/include/baresip.h
index 9ade882..90d038b 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.13"
+#define BARESIP_VERSION "0.4.14"
/* forward declarations */
diff --git a/mk/Doxyfile b/mk/Doxyfile
index fa223fc..acd6c62 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.13
+PROJECT_NUMBER = 0.4.14
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index c698010..8d246c3 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.13
+%define ver 0.4.14
%define rel 1
Summary: Modular SIP useragent