summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--docs/ChangeLog93
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
4 files changed, 96 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 887ff35..f5b4c25 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.5.6
+VERSION := 0.5.7
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 10c9a41..d79818e 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,96 @@
+2017-12-25 Alfred E. Heggestad <alfred.heggestad@gmail.com>
+
+ * Version 0.5.7
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.5.7
+ * NOTE: Requires libre v0.5.5 or later
+ Requires librem v0.5.0 or later
+
+ * Credits: Thanks to Swedish Radio who sponsored many new
+ features in this release.
+
+ * new commands:
+ - 'conf_reload' -- Reload config file
+
+ * new modules:
+ - gzrtp ZRTP module using GNU ZRTP C++ library
+ (thanks glenvt18)
+
+ - mqtt MQTT (Message Queue Telemetry Transport) module
+ (sponsored by Swedish Radio)
+
+ * config:
+ - audio_txmode poll|thread Set audio transmit mode
+ - auplay_format s16|float|s24_3le Set playback sample format
+ - ausrc_format s16|float|s24_3le Set source sample format
+ - sdp_ebuacip yes|no Enable EBU-ACIP parameters
+ - zrtp_hash yes|no Enable/disable ZRTP hash
+
+ * baresip-core:
+ - audio: add sample format conversion
+ - audio: add sample format for source/playback
+ - audio: check timestamps on incoming RTP packets
+ - audio: pace outgoing packets in txmode=thread
+ - audio: remove txmode with realtime thread
+ - audio: remove txmode with timer
+ - audio: set EBUACIP parameters in SDP
+ - auplay: add sample format to auplay_prm
+ - auplay: change write handler to any sample format
+ - ausrc: add sample format to ausrc_prm
+ - ausrc: change read handler to any sample format
+ - event.c: new file for generic event handling
+ - event: add event_encode_dict to encode event to a dictionary
+ - event: added UA_EVENT_CALL_RTCP for received RTCP
+ - log: print to stdout (ref #320)
+
+ * selftest:
+ - add test for different audio tx-modes
+ - add test for float audio sample format
+
+ * Modules:
+
+ * alsa: add support for multiple sample formats
+
+ * audiounit: add support for FLOAT sample format
+
+ * auloop: add support for multiple sample formats
+
+ * avahi: Bugfix: Destroy resolver after callback (#318)
+ (thanks Jonathan Sieber)
+
+ * avcodec: change x264 rate control mode to ABR (#334)
+ (thanks Jonathan Sieber)
+
+ * debug_cmd: add command 'conf_reload' to reload config file
+
+ * gzrtp: ZRTP module using GNU ZRTP C++ library
+ (thanks glenvt18)
+
+ * menu: add config 'ringback_disabled' to disable playing
+ of ringback tone.
+
+ * mqtt: MQTT (Message Queue Telemetry Transport) module
+ new module using libmosquitto as the backend.
+
+ * opus: fix encoder bitrate, ref #305
+ add opus_stereo config parameter (thanks Ola Palm)
+ add config param opus_sprop_stereo (thanks Ola Palm)
+
+ * portaudio: add support for FLOAT sample format
+
+ * pulse: add support for FLOAT sample format
+ remove garbage at the beginning of a recording (#323)
+
+ * quicktime: module was removed
+
+ * rst: add support for multiple sample formats
+
+ * zrtp: add signaling hash support (#311)
+
+
+
+
2017-10-14 Alfred E. Heggestad <alfred.heggestad@gmail.com>
* Version 0.5.6
diff --git a/include/baresip.h b/include/baresip.h
index f2aacad..746a95e 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.5.6"
+#define BARESIP_VERSION "0.5.7"
#ifndef NET_MAX_NS
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 30ee43a..3606286 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.5.6
+PROJECT_NUMBER = 0.5.7
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English