summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mk/modules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index ac16662..3fc85b4 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -69,9 +69,11 @@ USE_AMR := $(shell [ -d $(SYSROOT)/include/opencore-amrnb ] || \
[ -d $(SYSROOT)/include/amrnb ] && echo "yes")
USE_AVCODEC := $(shell [ -f $(SYSROOT)/include/libavcodec/avcodec.h ] || \
[ -f $(SYSROOT)/local/include/libavcodec/avcodec.h ] || \
+ [ -f $(SYSROOT)/include/$(MACHINE)/libavcodec/avcodec.h ] || \
[ -f $(SYSROOT_ALT)/include/libavcodec/avcodec.h ] && echo "yes")
USE_AVFORMAT := $(shell [ -f $(SYSROOT)/include/libavformat/avformat.h ] || \
[ -f $(SYSROOT)/local/include/libavformat/avformat.h ] || \
+ [ -f $(SYSROOT)/include/$(MACHINE)/libavformat/avformat.h ] || \
[ -f $(SYSROOT_ALT)/include/libavformat/avformat.h ] && echo "yes")
USE_BV32 := $(shell [ -f $(SYSROOT)/include/bv32/bv32.h ] || \
[ -f $(SYSROOT)/local/include/bv32/bv32.h ] && echo "yes")