summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mk/modules.mk7
-rw-r--r--modules/dtmfio/dtmfio.c9
2 files changed, 8 insertions, 8 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index db0a5a0..242299c 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -187,6 +187,7 @@ USE_QTCAPTURE := yes
endif
ifeq ($(OS),linux)
USE_EVDEV := $(shell [ -f $(SYSROOT)/include/linux/input.h ] && echo "yes")
+MODULES += dtmfio
endif
ifeq ($(OS),win32)
USE_WINWAVE := yes
@@ -347,9 +348,3 @@ endif
ifneq ($(USE_X11),)
MODULES += x11 x11grab
endif
-
-ifeq ($(OS),linux)
-MODULES += dtmfio
-endif
-
-
diff --git a/modules/dtmfio/dtmfio.c b/modules/dtmfio/dtmfio.c
index 10fdf43..5d9534c 100644
--- a/modules/dtmfio/dtmfio.c
+++ b/modules/dtmfio/dtmfio.c
@@ -65,6 +65,9 @@ static const char *DTMF_OUT = "/tmp/dtmf.out";
static void dtmf_handler(struct call *call, char key, void *arg)
{
+ (void)call;
+ (void)arg;
+
if ( key != 0 ) {
fprintf(fd, "%c", key);
fflush(fd);
@@ -78,6 +81,10 @@ static void ua_event_handler(struct ua *ua,
const char *prm,
void *arg )
{
+ (void)ua;
+ (void)prm;
+ (void)arg;
+
if ( ev == UA_EVENT_CALL_ESTABLISHED ) {
fprintf(fd, "E");
fflush(fd);
@@ -88,8 +95,6 @@ static void ua_event_handler(struct ua *ua,
fprintf(fd, "F");
fflush(fd);
}
-
- return;
}