summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog62
-rw-r--r--docs/README2
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
7 files changed, 73 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index f0c6ca1..efb6c7a 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.15
+VERSION := 0.4.16
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 37c6a62..8134488 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.16) unstable; urgency=low
+
+ * version 0.4.16
+
+ -- Alfred E. Heggestad <aeh@db.org> Tue, 1 Dec 2015 12:00:00 +0100
+
baresip (0.4.15) unstable; urgency=low
* version 0.4.15
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 49ee31e..1abbe85 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,65 @@
+2015-12-01 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.16
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT commit bed2241da3261e472f09b21958f0cc1324a94f27
+ * GIT tag: v0.4.16
+ * NOTE: Requires libre v0.4.14 or later
+
+ * new modules:
+ - v4l2_codec Video4Linux2 video codec (H264 hardware encoding)
+ - vidinfo Video info overlay module
+
+ * baresip-core:
+ - audio: add audio_set_source() and audio_set_player()
+ - audio: flush tx-buffer for all modes (thanks Thibault Gueslin)
+ - call: add call_is_outgoing()
+ - call: check address-family of incoming SDP offer (thanks Olle)
+ - h264: move H.264 packetization code to core
+ - main: add -u option to append extra global UA parameters
+ - main: pre-load modules after all arguments are parsed
+ - ua: add events UA_EVENT_SHUTDOWN,UA_EXIT
+ - ua: add ua_hold_answer()
+ - ua: add ua_set_media_af()
+ - ua: delay mod-unloading if mods has a ref to struct ua
+
+ * build:
+ - add verbose build with V=1 (thanks Dmitrij D. Czarkoff)
+ - add pkg-config file (thanks William King)
+ - add travis.yml file for Github build-system
+
+ * Modules:
+
+ * alsa: fix memory leaks
+
+ * avcodec: move common H.264 packetization code to core
+
+ * cairo: use pkg-config in makefile
+
+ * daala: update to latest libdaala (thanks Dmitrij D. Czarkoff)
+
+ * gst_video: use H.264 packetization API from core
+
+ * gst_video1: use H.264 packetization API from core
+
+ * gtk: fix segmentation fault on window close
+
+ * mwi: add 500ms delay after closing subscription
+
+ * oss: use pthread for ausrc instead of fd_listen (fixes FreeBSD)
+
+ * presence: use sipevent_sock instance from UA core
+ add 500ms delay after closing subscription
+
+ * v4l2_codec: new module
+
+ * vidinfo: new module
+
+ * zrtp: fix ZRTP over TURN by moving helper to layer 10
+ fix ZID verification (thanks Ingo Feinerer)
+
+
2015-09-26 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.15
diff --git a/docs/README b/docs/README
index ff1187f..737e519 100644
--- a/docs/README
+++ b/docs/README
@@ -317,7 +317,7 @@ Supported compilers:
External dependencies:
-libre v0.4.11 or later
+libre v0.4.14 or later
librem v0.4.6 or later
diff --git a/include/baresip.h b/include/baresip.h
index 1c164d9..401b7fc 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.15"
+#define BARESIP_VERSION "0.4.16"
/* forward declarations */
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 2655bbf..10be927 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.15
+PROJECT_NUMBER = 0.4.16
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index ac23046..4603797 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.15
+%define ver 0.4.16
%define rel 1
Summary: Modular SIP useragent