summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk16
1 files changed, 6 insertions, 10 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 3fc85b4..8973166 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -100,16 +100,12 @@ USE_GSM := $(shell [ -f $(SYSROOT)/include/gsm.h ] || \
[ -f $(SYSROOT)/include/gsm/gsm.h ] || \
[ -f $(SYSROOT)/local/include/gsm.h ] || \
[ -f $(SYSROOT)/local/include/gsm/gsm.h ] && echo "yes")
-USE_GST := $(shell [ -f $(SYSROOT)/include/gstreamer-0.10/gst/gst.h ] || \
- [ -f $(SYSROOT_ALT)/include/gstreamer-0.10/gst/gst.h ] && echo "yes")
-USE_GST1 := $(shell [ -f $(SYSROOT)/include/gstreamer-1.0/gst/gst.h ] || \
- [ -f $(SYSROOT_ALT)/include/gstreamer-1.0/gst/gst.h ] && echo "yes")
-USE_GST_VIDEO := \
- $(shell [ -f $(SYSROOT)/include/gstreamer-0.10/gst/gst.h ] || \
- [ -f $(SYSROOT_ALT)/include/gstreamer-0.10/gst/gst.h ] && echo "yes")
-USE_GST_VIDEO1 := \
- $(shell [ -f $(SYSROOT)/include/gstreamer-1.0/gst/gst.h ] || \
- [ -f $(SYSROOT_ALT)/include/gstreamer-1.0/gst/gst.h ] && echo "yes")
+USE_GST := $(shell pkg-config --exists gstreamer-0.10 && echo "yes")
+USE_GST1 := $(shell pkg-config --exists gstreamer-1.0 && echo "yes")
+USE_GST_VIDEO := $(shell pkg-config --exists gstreamer-0.10 gstreamer-app-0.10 \
+ && echo "yes")
+USE_GST_VIDEO1 := $(shell pkg-config --exists gstreamer-1.0 gstreamer-app-1.0 \
+ && echo "yes")
USE_ILBC := $(shell [ -f $(SYSROOT)/include/iLBC_define.h ] || \
[ -f $(SYSROOT)/local/include/iLBC_define.h ] && echo "yes")
USE_ISAC := $(shell [ -f $(SYSROOT)/include/isac.h ] || \