summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk22
1 files changed, 21 insertions, 1 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 2481f0e..dc93491 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -20,7 +20,10 @@
# USE_G722_1 G.722.1 audio codec
# USE_G726 G.726 audio codec
# USE_GSM GSM audio codec
-# USE_GST Gstreamer audio module
+# USE_GST Gstreamer 0.10 audio module
+# USE_GST1 Gstreamer 1.0 audio module
+# USE_GST_VIDEO Gstreamer 0.10 video module
+# USE_GST_VIDEO1 Gstreamer 1.0 video module
# USE_ILBC iLBC audio codec
# USE_ISAC iSAC audio codec
# USE_L16 L16 audio codec
@@ -97,6 +100,14 @@ USE_GSM := $(shell [ -f $(SYSROOT)/include/gsm.h ] || \
[ -f $(SYSROOT)/local/include/gsm/gsm.h ] && echo "yes")
USE_GST := $(shell [ -f $(SYSROOT)/include/gstreamer-0.10/gst/gst.h ] || \
[ -f $(SYSROOT_ALT)/include/gstreamer-0.10/gst/gst.h ] && echo "yes")
+USE_GST1 := $(shell [ -f $(SYSROOT)/include/gstreamer-1.0/gst/gst.h ] || \
+ [ -f $(SYSROOT_ALT)/include/gstreamer-1.0/gst/gst.h ] && echo "yes")
+USE_GST_VIDEO := \
+ $(shell [ -f $(SYSROOT)/include/gstreamer-0.10/gst/gst.h ] || \
+ [ -f $(SYSROOT_ALT)/include/gstreamer-0.10/gst/gst.h ] && echo "yes")
+USE_GST_VIDEO1 := \
+ $(shell [ -f $(SYSROOT)/include/gstreamer-1.0/gst/gst.h ] || \
+ [ -f $(SYSROOT_ALT)/include/gstreamer-1.0/gst/gst.h ] && echo "yes")
USE_ILBC := $(shell [ -f $(SYSROOT)/include/iLBC_define.h ] || \
[ -f $(SYSROOT)/local/include/iLBC_define.h ] && echo "yes")
USE_ISAC := $(shell [ -f $(SYSROOT)/include/isac.h ] || \
@@ -294,6 +305,15 @@ endif
ifneq ($(USE_GST),)
MODULES += gst
endif
+ifneq ($(USE_GST1),)
+MODULES += gst1
+endif
+ifneq ($(USE_GST_VIDEO),)
+MODULES += gst_video
+endif
+ifneq ($(USE_GST_VIDEO1),)
+MODULES += gst_video1
+endif
ifneq ($(USE_ILBC),)
MODULES += ilbc
endif