summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 57475d0..9211dfd 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -187,6 +187,9 @@ USE_SPEEX_PP := $(shell [ -f $(SYSROOT)/include/speex_preprocess.h ] || \
USE_SYSLOG := $(shell [ -f $(SYSROOT)/include/syslog.h ] || \
[ -f $(SYSROOT_ALT)/include/syslog.h ] || \
[ -f $(SYSROOT)/local/include/syslog.h ] && echo "yes")
+HAVE_LIBMQTT := $(shell [ -f $(SYSROOT)/include/mosquitto.h ] || \
+ [ -f $(SYSROOT)/local/include/mosquitto.h ] \
+ && echo "yes")
USE_V4L := $(shell [ -f $(SYSROOT)/include/libv4l1.h ] || \
[ -f $(SYSROOT)/local/include/libv4l1.h ] \
&& echo "yes")
@@ -273,6 +276,10 @@ MODULES += srtp
MODULES += uuid
MODULES += debug_cmd
+ifneq ($(HAVE_LIBMQTT),)
+MODULES += mqtt
+endif
+
ifneq ($(HAVE_PTHREAD),)
MODULES += aubridge aufile
endif