summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 8695814..1475247 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -30,6 +30,7 @@
# USE_ISAC iSAC audio codec
# USE_L16 L16 audio codec
# USE_LIBSRTP Secure RTP module using libsrtp
+# USE_MPA MPA audo codec
# USE_MPG123 Use mpg123
# USE_OPUS Opus audio codec
# USE_OSS OSS audio driver
@@ -147,6 +148,13 @@ ifeq ($(HAVE_SPEEXDSP),)
HAVE_SPEEXDSP := \
$(shell find $(SYSROOT)/lib -name libspeexdsp$(LIB_SUFFIX) 2>/dev/null)
endif
+ifneq ($(USE_MPG123),)
+ifneq ($(HAVE_SPEEXDSP),)
+USE_MPA := $(shell [ -f $(SYSROOT)/include/twolame.h ] || \
+ [ -f $(SYSROOT)/local/include/twolame.h ] || \
+ [ -f $(SYSROOT_ALT)/include/twolame.h ] && echo "yes")
+endif
+endif
USE_SPEEX := $(shell [ -f $(SYSROOT)/include/speex.h ] || \
[ -f $(SYSROOT)/include/speex/speex.h ] || \
[ -f $(SYSROOT)/local/include/speex.h ] || \
@@ -346,6 +354,9 @@ endif
ifneq ($(USE_OPUS),)
MODULES += opus
endif
+ifneq ($(USE_MPA),)
+MODULES += mpa
+endif
ifneq ($(USE_OSS),)
MODULES += oss
endif