summaryrefslogtreecommitdiff
path: root/mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk')
-rw-r--r--mk/modules.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 8f4f288..b103924 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -1,7 +1,7 @@
#
# modules.mk
#
-# Copyright (C) 2010 Creytiv.com
+# Copyright (C) 2010 - 2016 Creytiv.com
#
# External libraries:
#
@@ -37,6 +37,7 @@
# USE_OSS OSS audio driver
# USE_PLC Packet Loss Concealment
# USE_PORTAUDIO Portaudio audio driver
+# USE_PULSE Pulseaudio audio driver
# USE_SDL libSDL video output
# USE_SILK SILK (Skype) audio codec
# USE_SNDFILE sndfile wav dumper
@@ -136,6 +137,7 @@ USE_PLC := $(shell [ -f $(SYSROOT)/include/spandsp/plc.h ] || \
USE_PORTAUDIO := $(shell [ -f $(SYSROOT)/local/include/portaudio.h ] || \
[ -f $(SYSROOT)/include/portaudio.h ] || \
[ -f $(SYSROOT_ALT)/include/portaudio.h ] && echo "yes")
+USE_PULSE := $(shell pkg-config --exists libpulse && echo "yes")
USE_SDL := $(shell [ -f $(SYSROOT)/include/SDL/SDL.h ] || \
[ -f $(SYSROOT)/local/include/SDL/SDL.h ] || \
[ -f $(SYSROOT_ALT)/include/SDL/SDl.h ] && echo "yes")
@@ -377,6 +379,9 @@ endif
ifneq ($(USE_PORTAUDIO),)
MODULES += portaudio
endif
+ifneq ($(USE_PULSE),)
+MODULES += pulse
+endif
ifneq ($(USE_SDL),)
MODULES += sdl
endif