summaryrefslogtreecommitdiff
path: root/modules/avcodec/module.mk
diff options
context:
space:
mode:
Diffstat (limited to 'modules/avcodec/module.mk')
-rw-r--r--modules/avcodec/module.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/avcodec/module.mk b/modules/avcodec/module.mk
new file mode 100644
index 0000000..b209a57
--- /dev/null
+++ b/modules/avcodec/module.mk
@@ -0,0 +1,20 @@
+#
+# module.mk
+#
+# Copyright (C) 2010 Creytiv.com
+#
+
+USE_X264 := $(shell [ -f $(SYSROOT)/include/x264.h ] || \
+ [ -f $(SYSROOT)/local/include/x264.h ] || \
+ [ -f $(SYSROOT_ALT)/include/x264.h ] && echo "yes")
+
+MOD := avcodec
+$(MOD)_SRCS += avcodec.c h263.c h264.c encode.c decode.c
+$(MOD)_LFLAGS += -lavcodec -lavutil
+CFLAGS += -I/usr/include/ffmpeg
+ifneq ($(USE_X264),)
+CFLAGS += -DUSE_X264
+$(MOD)_LFLAGS += -lx264
+endif
+
+include mk/mod.mk