summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorRobert Fenk <fenk@users.sourceforge.net>2000-08-10 19:10:50 +0000
committerRobert Fenk <fenk@users.sourceforge.net>2000-08-10 19:10:50 +0000
commit710afdd43bed39aaa0bec3831c60f8f7c1bd0b2d (patch)
tree2f62971ca12221544db03aaa467aa33fb517e19b /ChangeLog
parentfd183a813b2c478cdd494bc55dea4bffd971b98f (diff)
Files: ChangeLog
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog52
1 files changed, 51 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 31d8152..9c25583 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,53 @@
+2000-08-10 Robert Fenk <fenk@forwiss.de>
+
+ * lisp/bbdb.el (bbdb-quiet-about-name-mismatches): if a number it
+ will be the number of seconds to sit-for when displaying the
+ notification about a name mismatch.
+ (bbdb-join): inverse function of bbdb-split.
+ (bbdb-annotate-message-sender): tries to guess a reasonable
+ default name when creating new records.
+
+ * lisp/bbdb-com.el (bbdb-define-all-aliases): Records without a
+ net nolonger cause a error, one will get just a waring when not
+ running in silent mode.
+ (bbdb-delete-current-field-or-record): added
+ handling of "*" in order to delete multiple records and 'noprompt'.
+ (bbdb-send-mail-internal): added missing call of vm hooks.
+ (bbdb-add-or-remove-mail-alias): returns all mail aliases in a format
+ suitable for completing read.
+ (bbdb-add-or-remove-mail-alias): convenience function for adding
+ or removing mail aliases from one or multiple records. This makes
+ it much simpler to define groups.
+
+ * lisp/bbdb-snarf.el (bbdb-snarf-nice-real-name-regexp): regexp
+ matching unwanted characters used by
+ (bbdb-snarf-nice-real-name): removes unwanted characters from real
+ names/email addresses.
+ (bbdb-extract-address-component-regexps): alist of regexps and
+ transformation-instructions used by
+ (bbdb-extract-address-components): is for the extraction of full
+ name and email address from headers. This function is a bit more
+ configurable than `mail-extract-address-components' and it will
+ return a list of all found address components.
+
+ * lisp/bbdb-vm.el (bbdb/vm-get-from): uses now
+ bbdb-extract-address-components to extract all recipients and uses
+ vm-summary-uninteresting-senders for ignoring senders, which is
+ more consistently with respect VM. One can set the variable
+ `bbdb/vm-get-from-headers' and `bbdb/vm-get-first-from-p' in order
+ to control what headers are processed and what is display is what
+ order.
+ (bbdb/vm-message-cache-lookup):
+ (bbdb/vm-encache-message): We use our own caching functions
+ instead of the bbdb default functions since we are handling a set
+ of records and not a single one.
+ (bbdb/vm-update-record): is now just a call to
+ (bbdb/vm-update-records): which performs the actual work of
+ finding and updating records.
+ (bbdb/vm-set-auto-folder-alist): Is a function from Mark Thomas
+ <mthomas@jprc.com> which sets `vm-auto-folder-alist' according to
+ the field `bbdb/vm-set-auto-folder-alist-field'.
+
2000-08-10 Sam Steingold <sds@gnu.org>
* lisp/bbdb.el (bbdb-annotate-notes): `regexp-quote' the
@@ -16,7 +66,7 @@
* lisp/Makefile (bbdb-autoloads.el): Added setting of variable
autoload-package-name and deletion of bbdb-autoloads.el file before
creation.
-
+
2000-08-01 Waider <waider@stepstone.ie>
* lisp/bbdb.el: