summaryrefslogtreecommitdiff
path: root/lisp
diff options
context:
space:
mode:
authorRonan Waide <waider@waider.ie>2000-10-15 17:22:22 +0000
committerRonan Waide <waider@waider.ie>2000-10-15 17:22:22 +0000
commit7066e876f9602b889b4328f88e26109169981427 (patch)
treef7ef1875d8ed8ce797aaa962b055807d5e118e03 /lisp
parent999a27ac005d1071594eeb4af7bb108fef800acb (diff)
Fix to allow building with Martin Schwenke's gnuserv.
Diffstat (limited to 'lisp')
-rw-r--r--lisp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lisp/Makefile b/lisp/Makefile
index e3cdfdd..cc1ddf9 100644
--- a/lisp/Makefile
+++ b/lisp/Makefile
@@ -107,7 +107,7 @@ bbdb-vm.elc: bbdb.elc bbdb-vm.el
-f batch-byte-compile $(@:.elc=.el)
bbdb-srv.elc: bbdb.elc bbdb-srv.el
- $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped - gnuserv not found"))'
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(or (fboundp (quote define-obsolete-variable-alias)) (if (locate-library "gnuserv-compat") (load-library "gnuserv-compat"))) (if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped - gnuserv not found"))'
bbdb-reportmail.elc: bbdb.elc bbdb-reportmail.el
$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (locate-library "reportmail") (byte-compile-file "bbdb-reportmail.el") (message "Optional package bbdb-reportmail skipped - reportmail not found"))'