summaryrefslogtreecommitdiff
path: root/tex
diff options
context:
space:
mode:
authorDidier Verna <didier@xemacs.org>2001-02-02 14:05:36 +0000
committerDidier Verna <didier@xemacs.org>2001-02-02 14:05:36 +0000
commitbd6f08fd7cb117f1890d8f202960e2d87cf6ad48 (patch)
tree79b78b8b97ac38e588718076e59d4e93e11e8590 /tex
parent8d237bbda84a37a62e87a62f8b284e69f002ceac (diff)
makefile for tex dir
Diffstat (limited to 'tex')
-rw-r--r--tex/.cvsignore1
-rw-r--r--tex/Makefile.in39
2 files changed, 40 insertions, 0 deletions
diff --git a/tex/.cvsignore b/tex/.cvsignore
new file mode 100644
index 0000000..f3c7a7c
--- /dev/null
+++ b/tex/.cvsignore
@@ -0,0 +1 @@
+Makefile
diff --git a/tex/Makefile.in b/tex/Makefile.in
new file mode 100644
index 0000000..6fb23af
--- /dev/null
+++ b/tex/Makefile.in
@@ -0,0 +1,39 @@
+@SET_MAKE@
+
+INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_DATA = @INSTALL_DATA@
+
+LN_S = @LN_S@
+
+PACKAGEDIR = @PACKAGEDIR@
+SYMLINKS = @SYMLINKS@
+LINKPATH = @LINKPATH@
+
+install-pkg: uninstall-pkg
+ @if test "x$(SYMLINKS)" = "xno" ; then \
+ mkdir -p -m 0755 $(PACKAGEDIR)/etc/bbdb/tex ; \
+ for i in `ls *.tex` ; do \
+ $(INSTALL_DATA) $$i $(PACKAGEDIR)/etc/bbdb/tex/ ; \
+ done ; \
+ else \
+ if test "x$(LINKPATH)" = "x" ; then \
+ $(LN_S) `pwd` $(PACKAGEDIR)/etc/bbdb/tex ; \
+ else \
+ $(LN_S) $(LINKPATH)/tex $(PACKAGEDIR)/etc/bbdb/tex ; \
+ fi ; \
+ fi
+
+uninstall-pkg:
+ -$(RM) -r $(PACKAGEDIR)/etc/bbdb/tex
+
+clean:
+
+distclean: clean
+
+# Backward compatibility:
+reallyclean: distclean
+
+cvsclean: distclean
+ -$(RM) Makefile