summaryrefslogtreecommitdiff
path: root/debian/patches/debian-changes
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian-changes')
-rw-r--r--debian/patches/debian-changes494
1 files changed, 494 insertions, 0 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 0000000..795314b
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,494 @@
+Description: <short summary of the patch>
+ TODO: Put a short summary on the line above and replace this paragraph
+ with a longer explanation of this change. Complete the meta-information
+ with other relevant fields (see below for details). To make it easier, the
+ information below has been extracted from the changelog. Adjust it or drop
+ it.
+ .
+ bbdb (2.36-4) unstable; urgency=medium
+ .
+ * engage dh autoreconf, rm ./configure, relax regarding ./configure +x bit
+ * updates to debian/README.Debian and debian/README.source
+ * remove CVS keyword expansion artifacts
+ * add savannah repo pointers to bbdb.texinfo
+ * remove PHONY stuff in debian/rules
+ * remove stray old-style quasiquote in macro
+ * allow emacs24 to satisfy dependencies
+ * bump standards version, dh version
+ * single debian patch source option
+Author: Barak A. Pearlmutter <bap@debian.org>
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: http://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: <YYYY-MM-DD>
+
+--- bbdb-2.36.orig/ChangeLog
++++ bbdb-2.36/ChangeLog
+@@ -1,3 +1,12 @@
++2010-06-03 Barak A. Pearlmutter <barak@cs.nuim.ie>
++
++ * texinfo/bbdb.texinfo: include pointers to github repo.
++
++2010-09-29 Julien Danjou <julien@danjou.info>
++
++ * lisp/bbdb-gnus.el (bbdb/gnus-split-myaddr-regexp): Remove usage
++ of deprecated gnus-local-domain.
++
+ 2010-04-20 Barak A. Pearlmutter <barak@cs.nuim.ie>
+
+ * README: Emacs, meaning both GNU Emacs and XEmacs.
+--- /dev/null
++++ bbdb-2.36/bits/bbdb-adapt-ispell.el
+@@ -0,0 +1,120 @@
++;;; bbdbadapt-ispell.el --- Use the BBDB to insert a gcc field
++
++;; Copyright (C) 2009 Uwe Brauer
++
++;; Author: Uwe Brauer oub@mat.ucm.es
++;; Maintainer: Uwe Brauer oub@mat.ucm.es
++;; Created: 17 Mar 2009
++;; Version: 1.0
++;; Keywords:
++
++
++;; This program is free software; you can redistribute it and/or modify
++;; it under the terms of the GNU General Public License as published by
++;; the Free Software Foundation; either version 1, or (at your option)
++;; any later version.
++
++;; This program is distributed in the hope that it will be useful,
++;; but WITHOUT ANY WARRANTY; without even the implied warranty of
++;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++;; GNU General Public License for more details.
++
++;; A copy of the GNU General Public License can be obtained from this
++;; program's author (send electronic mail to oub@mat.ucm.es) or from
++;; the Free Software Foundation, Inc., 675 Mass Ave, Cambridge, MA
++;; 02139, USA.
++
++;; LCD Archive Entry:
++;; bbdbadpt-gcc|Uwe Brauer|oub@mat.ucm.es
++;; |Use the BBDB to insert a gcc field
++;; |Date|Revision|~/packages/bbdbadpt-gcc.el
++
++;;; Commentary:
++;; I wanted to have the ispell dict selected
++;; based on a relevant bbdb entry which I call ispell-dict.
++;; This is what the code does.
++
++;; The starting point was some code provided to me by Robert
++;; Fenk. However the problem with that code was that it took the gcc
++;; field from some entry of the BBDB buffer and if there was more than
++;; on entry often the wrong string was inserted. So I had to use code
++;; which extracted the correct BBDB entry from the TO field . I
++;; succeeded by using to a large extend code from sigadapt.el written
++;; by by C.Queinnec (University of Paris 6 & INRIA)
++;;
++
++;;; Change log:
++;; Revision 1.1 2009/03/17 17:27:31 oub
++;; Initial revision
++;;
++;; Revision 1.2 2009/03/17 16:50:20 oub
++;; modify the central function
++;;
++;; Revision 1.1 2009/03/17 16:32:26 oub
++;; Initial revision
++;;
++
++;;; Code:
++
++
++
++
++(defun bbdbispelladpt-search-record (to)
++ "Search a BBDB record associated to TO or return NIL."
++ (let* ((data (mail-extract-address-components to))
++ (name (car data))
++ (net (car (cdr data))))
++ (if (equal name net) (setq name nil))
++ (if (and net bbdb-canonicalize-net-hook)
++ (setq net (bbdb-canonicalize-address net)))
++ (bbdb-search-simple name net)))
++
++(defun bbdbispelladpt-try-bbdbispell-new ()
++ "Try to adapt non-interactively the current bbdbispell.
++This function looks silently in the current message to find how to
++choose the bbdbispell. It does nothinng if not enough information is
++present. This function is useful in a hook."
++ (save-excursion
++ (condition-case nil
++ (progn
++ (goto-char (point-min))
++ (let ((record (bbdbispelladpt-search-record
++ (bbdb-extract-field-value "To"))))
++ (if record
++ (let ((signame (bbdbispelladpt-retrieve-bbdbispell record)))
++ (when (and (stringp signame) (string= signame "castellano8"))
++ (ispell-change-dictionary "castellano8" nil))
++ (when (and (stringp signame) (string= signame "english"))
++ (ispell-change-dictionary "american" nil ))
++ (when (and (stringp signame) (string= signame "deutsch"))
++ (ispell-change-dictionary "deutsch8" nil))
++ (when (and (stringp signame) (string= signame "french"))
++ (ispell-change-dictionary "francais" nil)))))))))
++
++
++
++
++(defun bbdbispelladpt-retrieve-bbdbispell (&optional record)
++ "Retrieve the bbdbispell (a symbol) associated to a mailee.
++The search is done through a BBDB record. "
++ (if (not record)
++ (save-excursion
++ (goto-char (point-min))
++ (let* ((to (bbdb-extract-field-value "To"))
++ (rec (bbdbispelladpt-search-record to)) )
++ (if rec (bbdbispelladpt-do-retrieve-bbdbispell rec)
++ (progn (message "No bound record")
++ nil))))
++ (bbdbispelladpt-do-retrieve-bbdbispell record) ) )
++
++(defun bbdbispelladpt-do-retrieve-bbdbispell (record)
++ (let ((signame
++ (bbdb-record-getprop record 'ispell-dict)))
++ (if (stringp signame)
++ (setq signame signame))
++ signame))
++
++
++(provide 'bbdbadapt-ispell)
++
++;;; BBDBADPT-ISPELL.EL ends here
+--- bbdb-2.36.orig/bits/bbdb-gnokii.el
++++ bbdb-2.36/bits/bbdb-gnokii.el
+@@ -8,7 +8,6 @@
+ ;; Len Trigg <len@reeltwo.com>
+ ;; Maintainer: Martin Schwenke <martin@meltin.net>
+ ;; Created: 23 August 2000
+-;; $Id: bbdb-gnokii.el,v 1.16 2006/04/19 13:02:09 martins Exp $
+ ;; Keywords: BBDB, Nokia, gnokii
+ ;; X-URL: http://meltin.net/hacks/emacs/
+
+@@ -172,7 +171,6 @@
+
+ ;;; History:
+
+-;; $Log: bbdb-gnokii.el,v $
+ ;; Revision 1.16 2006/04/19 13:02:09 martins
+ ;; Function bbdb-gnokii-do-name now just uses firstname if lastname is
+ ;; not set. Suggested by Magnus Henoch <mange@freemail.hu>.
+--- bbdb-2.36.orig/bits/bbdb-ldif.el
++++ bbdb-2.36/bits/bbdb-ldif.el
+@@ -1,6 +1,5 @@
+ ;;; Copyright (C) 1998,2000 by Niels Elgaard Larsen <elgaard@diku.dk>
+
+-;;; $Log: bbdb-ldif.el,v $
+ ;;; Revision 1.1 2006/02/04 15:35:15 joerg
+ ;;; Added
+ ;;;
+--- bbdb-2.36.orig/bits/bbdb-mail-folders.el
++++ bbdb-2.36/bits/bbdb-mail-folders.el
+@@ -61,7 +61,6 @@
+ ;(310) 822-1511 University of Southern California
+ ;http://www.isi.edu/div7/people/cengiz.home
+
+-;$Modified: Fri Nov 20 11:41:56 1998 by ville@isr.umd.edu $
+ ; GV: - always expand filename to avoid duplicate similar path
+ ; - use abbreviation alist for home directory (comes from mode-line)
+
+--- bbdb-2.36.orig/bits/bbdb-mew.el
++++ bbdb-2.36/bits/bbdb-mew.el
+@@ -11,7 +11,6 @@
+ ;; Mitsuo Nishizawa <mitsuo@phys2.med.osaka-u.ac.jp>
+ ;; Maintenance: Chris Beggy
+ ;; Created: 1996/11/04
+-;; Version: $Id: bbdb-mew.el,v 1.5 2001/12/29 16:12:20 chrisb Exp $
+
+ ;; Keywords: mail, BBDB
+
+--- bbdb-2.36.orig/bits/bbdb-obsolete.el
++++ bbdb-2.36/bits/bbdb-obsolete.el
+@@ -4,7 +4,6 @@
+
+ ;; Author: Colin Rafferty <colin@xemacs.org>
+ ;; Keywords: bbdb, net, obsolete
+-;; Version: $Id: bbdb-obsolete.el,v 1.3 2006/02/04 15:34:30 joerg Exp $
+
+ ;; This program is free software; you can redistribute it and/or modify
+ ;; it under the terms of the GNU General Public License as published by
+--- bbdb-2.36.orig/bits/bbdb-pgp.el
++++ bbdb-2.36/bits/bbdb-pgp.el
+@@ -5,7 +5,6 @@
+ ;; Author: Kevin Davidson tkld@quadstone.com
+ ;; Maintainer: Kevin Davidson tkld@quadstone.com
+ ;; Created: 10 Nov 1997
+-;; Version: $Revision: 1.6 $
+ ;; Keywords: PGP BBDB message mailcrypt
+
+
+@@ -27,7 +26,7 @@
+ ;; LCD Archive Entry:
+ ;; bbdb-pgp|Kevin Davidson|tkld@quadstone.com
+ ;; |Use BBDB to store PGP preferences
+-;; |$Date: 2003/08/11 08:54:35 $|$Revision: 1.6 $|~/packages/bbdb-pgp.el
++;; |Date|Revision|~/packages/bbdb-pgp.el
+
+ ;;; Commentary:
+ ;;
+@@ -74,11 +73,6 @@
+ (require 'bbdb)
+ (condition-case nil (require 'mailcrypt) (error nil))
+
+-(defconst bbdb/pgp-version (substring "$Revision: 1.6 $" 11 -2)
+- "$Id: bbdb-pgp.el,v 1.6 2003/08/11 08:54:35 waider Exp $
+-
+-Report bugs to: Kevin Davidson tkld@quadstone.com")
+-
+ ;;;###autoload
+ (defgroup bbdb-utilities-pgp nil
+ "Automatically sign and/or encrypt outgoing messages."
+--- bbdb-2.36.orig/bits/bbdb-signature.el
++++ bbdb-2.36/bits/bbdb-signature.el
+@@ -23,7 +23,7 @@
+ ;;; LCD Archive Entry:
+ ;;; mail-signature|Kevin Davidson|<tkld@quadstone.com>
+ ;;; |Add context sensitive signature
+-;;; |$Date: 2001/03/01 15:38:31 $|$Revision: 1.1 $|~/packages/mail-signature.el
++;;; |Date|Revision|~/packages/mail-signature.el
+
+ ;;; Commentary:
+
+@@ -54,7 +54,6 @@
+ ;;; (setq message-signature 'mail-signature)
+
+ ;;; Change log:
+-;; $Log: bbdb-signature.el,v $
+ ;; Revision 1.1 2001/03/01 15:38:31 waider
+ ;; More bits, possibly incompatible with 2.00.06. Use at own risk.
+ ;;
+@@ -79,11 +78,6 @@
+
+ ;;; Code:
+
+-(defconst mail-signature-version (substring "$Revision: 1.1 $" 11 -2)
+- "$Id: bbdb-signature.el,v 1.1 2001/03/01 15:38:31 waider Exp $
+-
+-Report bugs to: Kevin Davidson <tkld@quadstone.com>")
+-
+
+ (defvar bbdb-signature-field 'signature
+ "*BBDB field used to store signature for")
+--- bbdb-2.36.orig/bits/bbdb-sort-mailrc.el
++++ bbdb-2.36/bits/bbdb-sort-mailrc.el
+@@ -18,7 +18,6 @@
+ ;;; BBDB-BNG
+ ;;; Various functions I have added to enhance the big brother database.
+ ;;; Boris Goldowsky, <boris@cs.rochester.edu>
+-;;; $Revision: 1.1 $ $Date: 2001/01/24 21:19:08 $
+ ;;;
+ ;;; This file allows you to do the following things:
+ ;;; * Sort by firstname or company rather than last name.
+--- bbdb-2.36.orig/bits/bbdb-vcard-export.el
++++ bbdb-2.36/bits/bbdb-vcard-export.el
+@@ -19,7 +19,6 @@
+ ;;
+ ;; Author: Jim Hourihan <jimh@panix.com>
+ ;; Created: 2002-08-08
+-;; Version: $Id: bbdb-vcard-export.el,v 1.3 2006/03/14 00:00:00 malcolmp Exp $
+ ;; Keywords: vcard ipod
+
+ ;;; Commentary
+--- bbdb-2.36.orig/bits/bbdb-vcard-import.el
++++ bbdb-2.36/bits/bbdb-vcard-import.el
+@@ -18,7 +18,6 @@
+ ;;
+ ;; Author: Marcus Crestani <crestani@informatik.uni-tuebingen.de>
+ ;; Created: 2008-01-03
+-;; Version: $Id: bbdb-vcard-import.el,v 1.6 2008/01/31 16:19:15 cvs Exp $
+ ;; Keywords: vcard bbdb
+ ;;
+ ;; This requires vcard.el by NoahFriedman for the importer to work.
+--- bbdb-2.36.orig/bits/bbdbpalm.el
++++ bbdb-2.36/bits/bbdbpalm.el
+@@ -5,7 +5,6 @@
+ ;; Author: Neil W. Van Dyke <neil@neilvandyke.org>
+ ;; Version: 0.3
+ ;; X-URL: http://www.neilvandyke.org/bbdbpalm/
+-;; X-CVS: $Id: bbdbpalm.el,v 1.26 2006-11-12 04:46:58 neil Exp $
+
+ ;; This is free software; you can redistribute it and/or modify it under the
+ ;; terms of the GNU General Public License as published by the Free Software
+--- bbdb-2.36.orig/bits/vcard.el
++++ bbdb-2.36/bits/vcard.el
+@@ -7,8 +7,6 @@
+ ;; Keywords: vcard, mail, news
+ ;; Created: 1997-09-27
+
+-;; $Id: vcard.el,v 1.11 2000/06/29 17:07:55 friedman Exp $
+-
+ ;; This program is free software; you can redistribute it and/or modify
+ ;; it under the terms of the GNU General Public License as published by
+ ;; the Free Software Foundation; either version 2, or (at your option)
+--- bbdb-2.36.orig/configure.ac
++++ bbdb-2.36/configure.ac
+@@ -23,7 +23,7 @@ dnl Inc., 675 Mass Ave, Cambridge, MA 02
+
+ dnl Process this file with autoconf to produce a new configure script
+
+-AC_PREREQ(2.65)
++AC_PREREQ([2.67])
+
+ BBDB_PRE_INIT
+ AC_INIT([BBDB],[BBDB_VERSION],[bbdb-info@lists.sourceforge.net])
+--- bbdb-2.36.orig/html/faq.html
++++ bbdb-2.36/html/faq.html
+@@ -11,7 +11,7 @@
+ in the mailing list archives. Feel free to mail me any things that should
+ be on this list.
+
+- <p>This is the BBDB FAQ, $Revision: 1.6 $.</p>
++ <p>This is the BBDB FAQ.</p>
+
+ <dl>
+ <dt>About BBDB and this document</dt>
+@@ -332,6 +332,5 @@
+
+ <hr>
+ <address>bbdb-faq@waider.ie</address>
+- $Date: 2007/01/30 22:05:41 $
+ </body>
+ </html>
+--- bbdb-2.36.orig/lisp/bbdb-gnus.el
++++ bbdb-2.36/lisp/bbdb-gnus.el
+@@ -580,13 +580,11 @@ excellent choice."
+ (defcustom bbdb/gnus-split-myaddr-regexp
+ (concat "^" (user-login-name) "$\\|^"
+ (user-login-name) "@\\([-a-z0-9]+\\.\\)*"
+- (or gnus-local-domain (message-make-domain)
++ (or (message-make-domain)
+ (system-name) "") "$")
+- "*This regular expression should match your address as found in the
+-From header of your mail. You should make sure gnus-local-domain or
+-gnus-use-generic-from are set before loading this module, if they differ
+-from (system-name). If you send mail/news from multiple addresses, then
+-you'll likely have to set this yourself anyways."
++ "This regular expression should match your address as found in
++the From header of your mail. If you send mail/news from multiple
++addresses, then you'll likely have to set this yourself anyway."
+ :group 'bbdb-mua-specific-gnus-splitting
+ :type 'string)
+
+--- bbdb-2.36.orig/lisp/bbdb-mhe.el
++++ bbdb-2.36/lisp/bbdb-mhe.el
+@@ -33,20 +33,20 @@
+
+ (defmacro bbdb/mh-cache-key (message)
+ "Return a (numeric) key for MESSAGE"
+- (`(let* ((attrs (file-attributes (, message)))
+- (status-time (nth 6 attrs))
+- (status-time-2 (cdr status-time))
+- (inode (nth 10 attrs)))
+- (logxor (if (integerp inode) ;; if inode is larger than an emacs int,
+- inode ;; it's returned as a dotted pair
+- (car inode))
+- (car status-time)
+- ;; We need the following test because XEmacs returns the
+- ;; status time as a dotted pair, whereas FSF and Epoch
+- ;; return it as list.
+- (if (integerp status-time-2)
+- status-time-2
+- (car status-time-2))))))
++ `(let* ((attrs (file-attributes , message))
++ (status-time (nth 6 attrs))
++ (status-time-2 (cdr status-time))
++ (inode (nth 10 attrs)))
++ (logxor (if (integerp inode) ;; if inode is larger than an emacs int,
++ inode ;; it's returned as a dotted pair
++ (car inode))
++ (car status-time)
++ ;; We need the following test because XEmacs returns the
++ ;; status time as a dotted pair, whereas FSF and Epoch
++ ;; return it as list.
++ (if (integerp status-time-2)
++ status-time-2
++ (car status-time-2)))))
+
+ ;;;###autoload
+ (defun bbdb/mh-update-record (&optional offer-to-create)
+--- bbdb-2.36.orig/texinfo/bbdb.texinfo
++++ bbdb-2.36/texinfo/bbdb.texinfo
+@@ -3527,6 +3527,10 @@ where @var{NAME} is the symbol for the n
+ (If you are looking for a way to create mailing lists with @b{BBDB}, you
+ should be looking at the section on @xref{Mail Sending Interfaces}.)
+
++The locus of BBDB development is moving to savannah,
++@code{https://savannah.nongnu.org/projects/bbdb/},
++making the below of mainly historic interest.
++
+ There are three mailing lists for the @b{BBDB}.
+ @code{bbdb-info@@lists.sourceforge.net} gets moderate traffic, and is
+ intended for the discussion and distribution of development versions of
+@@ -3543,6 +3547,9 @@ intended for developers to follow the ch
+ development version. Developers of the @b{BBDB} should consider to
+ subscribe to this list.
+
++There is also an issue tracker associated with the @b{BBDB}
++repository at @code{http://github.com/barak/BBDB}.
++
+ @node Changes, The Latest Version, Mailing Lists, Top
+ @section Changes in this Version
+
+@@ -3592,6 +3599,13 @@ and Courier fonts are used.
+ @node The Latest Version, The Future, Changes, Top
+ @section The Latest Version
+
++The locus of BBDB development is moving to savannah,
++@code{https://savannah.nongnu.org/projects/bbdb/},
++making the below of mainly historic interest.
++Development of the new v3 version, as well and maintenance releases of
++v2.x, will be available in the associated git repository,
++@code{git://git.savannah.nongnu.org/bbdb.git}.
++
+ @noindent
+ Released versions of the @b{BBDB} can be found at the
+ following site:
+@@ -3601,6 +3615,8 @@ following site:
+ WWW: @code{http://bbdb.sourceforge.net}
+ @item
+ FTP: @code{ftp://ftp.sourceforge.net/pub/bbdb}
++@item
++Git Fork: @code{http://github.com/barak/BBDB}
+ @end itemize
+
+ @noindent
+@@ -3612,6 +3628,8 @@ following ways:
+ WWW: @code{http://bbdb.sourceforge.net}
+ @item
+ Anonymous CVS: See @code{http://bbdb.sourceforge.net} for instructions.
++@item
++Git Fork: @code{http://github.com/barak/BBDB}
+ @end itemize
+
+ Users of development versions of the @b{BBDB} should subscribe to the
+--- bbdb-2.36.orig/utils/bbdb-unlazy-lock.pl
++++ bbdb-2.36/utils/bbdb-unlazy-lock.pl
+@@ -2,9 +2,6 @@
+ #
+ # Author: Christopher Kline <ckline@media.mit.edu>
+ #
+-# $Id: bbdb-unlazy-lock.pl,v 1.1 1997/10/06 00:56:14 simmonmt Exp $
+-#
+-# $Log: bbdb-unlazy-lock.pl,v $
+ # Revision 1.1 1997/10/06 00:56:14 simmonmt
+ # Initial revision
+ #