summaryrefslogtreecommitdiff
path: root/testing/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'testing/Makefile.in')
-rw-r--r--testing/Makefile.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/Makefile.in b/testing/Makefile.in
new file mode 100644
index 0000000..85d2c22
--- /dev/null
+++ b/testing/Makefile.in
@@ -0,0 +1,8 @@
+all: bbdb-test-results
+
+bbdb-test-results: ../lisp bbdb-test.el
+ @EMACS_PROG@ -no-site-file -no-init-file -batch -l run-tests.el >/dev/null 2>&1
+ @if @GREP@ FAILED bbdb-test-results >/dev/null 2>&1; then echo "Tests failed:"; @GREP@ @GREPCONTEXT@ -n FAILED bbdb-test-results; else echo "All tests succeeded"; fi
+
+clean:
+ @RM@ bbdb-test-results