summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:23 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:23 -0400
commit04e7ba8bf082e2b170595eef488834accd9d946e (patch)
tree7fd20434fc62c1d7feb47de9d2d4ad6b533198d4
parentcbb6dcfb002dd5bc5f702a4909306be5c2878319 (diff)
Imported Upstream version 2.0.1
-rw-r--r--CMakeLists.txt4
-rw-r--r--ChangeLog10
-rw-r--r--src/backend/rendering/cdisplayrendering.cpp6
-rw-r--r--src/bibletime.cpp2
-rw-r--r--src/frontend/display/bthtmlreaddisplay.cpp10
-rw-r--r--src/util/cresmgr.cpp3
-rw-r--r--src/util/cresmgr.h3
7 files changed, 25 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9274447..e2f052b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@ PROJECT(bibletime CXX C)
CMAKE_MINIMUM_REQUIRED(VERSION 2.4.0)
#Version
-ADD_DEFINITIONS(-DBT_VERSION=\\\"2.0\\\")
+ADD_DEFINITIONS(-DBT_VERSION=\\\"2.0.1\\\")
#Non-English locales to be processed and installed for UI, handbook and howto
LIST(APPEND MESSAGE_LOCALE_LANGS af bg cs da de en_GB es et fi fr hu it ko nl nn_NO no pl pt_br ro ru sk sv ua vi zh_CN zh_TW)
@@ -307,7 +307,7 @@ SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "BibleTime for Windows Beta")
SET(CPACK_PACKAGE_VENDOR "http://www.bibletime.info")
SET(CPACK_PACKAGE_VERSION_MAJOR "2")
SET(CPACK_PACKAGE_VERSION_MINOR "0")
-SET(CPACK_PACKAGE_VERSION_PATCH "0")
+SET(CPACK_PACKAGE_VERSION_PATCH "1")
SET(CPACK_PACKAGE_INSTALL_DIRECTORY "BibleTime")
######################################################
diff --git a/ChangeLog b/ChangeLog
index fd0afa1..ce7b6a8 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2009-06-06 Martin Gruner <mgruner@crosswire.org>
+ * Release 2.0.1
+
+2009-06-02 Martin Gruner <mgruner@crosswire.org>
+ * Fix bug #2799800: Display broken when verse numbers are turned off
+
+2009-05-30 Gary Holmlund
+ * Fix defect, the main window icon was missing - defect # 2798758
+ * Removed debug code writing a out.txt file in the current directory without warning
+
2009-05-28 Martin Gruner <mgruner@crosswire.org>
* release 2.0
diff --git a/src/backend/rendering/cdisplayrendering.cpp b/src/backend/rendering/cdisplayrendering.cpp
index 8c6c525..50d5b18 100644
--- a/src/backend/rendering/cdisplayrendering.cpp
+++ b/src/backend/rendering/cdisplayrendering.cpp
@@ -19,6 +19,7 @@
//Qt
#include <QString>
#include <QRegExp>
+#include <QDebug>
namespace Rendering {
@@ -80,8 +81,9 @@ namespace Rendering {
}
}
+
if (linkText.isEmpty()) {
- return QString("<a name=\"").append(keyToHTMLAnchor(item.key())).append("\" />");
+ return QString("<a name=\"").append(keyToHTMLAnchor(item.key())).append("\"></a>");
}
else {
return QString("<a name=\"").append(keyToHTMLAnchor(item.key())).append("\" ")
@@ -147,7 +149,7 @@ namespace Rendering {
CDisplayTemplateMgr::Settings settings;
settings.modules = modules;
settings.langAbbrev = ((modules.count() == 1) && lang->isValid()) ? lang->abbrev() : QString::null;
-
+
if (modules.count() == 1)
settings.pageDirection = (modules.first()->textDirection() == CSwordModuleInfo::LeftToRight) ? "ltr" : "rtl";
else
diff --git a/src/bibletime.cpp b/src/bibletime.cpp
index c4510f6..0877a8f 100644
--- a/src/bibletime.cpp
+++ b/src/bibletime.cpp
@@ -20,6 +20,7 @@
#include "util/ctoolclass.h"
#include "util/cpointers.h"
+#include "util/cresmgr.h"
#include "util/directoryutil.h"
#include "backend/drivers/cswordmoduleinfo.h"
@@ -75,6 +76,7 @@ BibleTime::BibleTime() :
initConnections();
readSettings();
setPlainCaption(QString());
+ setWindowIcon( util::filesystem::DirectoryUtil::getIcon(CResMgr::mainWindow::icon) );
}
BibleTime::~BibleTime()
diff --git a/src/frontend/display/bthtmlreaddisplay.cpp b/src/frontend/display/bthtmlreaddisplay.cpp
index 6cb959c..53d10e7 100644
--- a/src/frontend/display/bthtmlreaddisplay.cpp
+++ b/src/frontend/display/bthtmlreaddisplay.cpp
@@ -213,19 +213,11 @@ const QString BtHtmlReadDisplay::text( const CDisplay::TextType format, const CD
return QString();
}
-#include <QTextStream>
// Puts html text and javascript into QWebView
void BtHtmlReadDisplay::setText( const QString& newText )
{
QString jsText = newText;
- QFile file("out.txt");
- if (!file.open(QIODevice::WriteOnly | QIODevice::Text))
- return;
-
- QTextStream out(&file);
- out << newText << "\n";
-
jsText.replace(body,jsBegin+javascript+jsEnd+body);
// Disconnect any previous connect and connect to slot that loads the javascript object
@@ -379,4 +371,4 @@ bool BtHtmlReadDisplayView::event(QEvent* e)
if ( e->type() == QEvent::Leave )
m_display->m_jsObject->clearPrevAttribute();
return QWidget::event(e);
-} \ No newline at end of file
+}
diff --git a/src/util/cresmgr.cpp b/src/util/cresmgr.cpp
index 1bd51af..27eb8f4 100644
--- a/src/util/cresmgr.cpp
+++ b/src/util/cresmgr.cpp
@@ -13,6 +13,9 @@
namespace CResMgr {
+ namespace mainWindow {
+ const QString icon = "bibletime.svg";
+ } // mainWindow
namespace modules {
namespace bible {
const QString icon_unlocked = "bible.svg";
diff --git a/src/util/cresmgr.h b/src/util/cresmgr.h
index 1fa3953..95d931e 100644
--- a/src/util/cresmgr.h
+++ b/src/util/cresmgr.h
@@ -20,6 +20,9 @@
namespace CResMgr {
void init_tr();
+ namespace mainWindow {
+ extern const QString icon;
+ }
namespace modules {
namespace bible {
extern const QString icon_unlocked;