summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnibal Monsalve Salazar <anibal@debian.org>2014-06-27 11:59:08 +0100
committerRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:56 -0400
commitd40aeea533995281ebf64c52e69340764de6f3d9 (patch)
treed2d1830ae7fd1c0afc2707d4f7191a526b5d9513
parent26eaa6590c955fc3e71f9d9163a55315246680ff (diff)
Imported Debian patch 2.9.2-1.1
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/libsword-1.7.patch74
-rw-r--r--debian/patches/series1
3 files changed, 86 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4953b80..098a9e2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+bibletime (2.9.2-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Build with libsword 1.7.
+ Add libsword-1.7.patch.
+ Patch by Plamen Aleksandrov <plamen@aomeda.com>.
+ Work done as part of a Debian GSOC 2014 project.
+ Closes: #748685.
+
+ -- Anibal Monsalve Salazar <anibal@debian.org> Fri, 27 Jun 2014 11:59:08 +0100
+
bibletime (2.9.2-1) unstable; urgency=low
* New upstream release
diff --git a/debian/patches/libsword-1.7.patch b/debian/patches/libsword-1.7.patch
new file mode 100644
index 0000000..a392615
--- /dev/null
+++ b/debian/patches/libsword-1.7.patch
@@ -0,0 +1,74 @@
+From: Plamen Aleksandrov <plamen@aomeda.com>
+Subject: patch for bibletime 2.9
+Date: Wed, 18 Jun 2014 16:23:33 +0300
+
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=748685
+
+This patch fixes the compilation of bibletime 2.9 with libsword 1.7.
+
+diff -urN a/cmake/sword_linker_check.cpp b/cmake/sword_linker_check.cpp
+--- a/cmake/sword_linker_check.cpp 2013-06-03 18:08:52.000000000 +0000
++++ b/cmake/sword_linker_check.cpp 2014-06-16 12:49:05.979470653 +0000
+@@ -15,13 +15,13 @@
+
+ #include <swmgr.h>
+ #include <installmgr.h>
+-#include <ftptrans.h>
++#include <curlftpt.h>
+
+ int main(int argc, char* argv[])
+ {
+ sword::SWMgr mgr;
+ sword::InstallMgr imgr;
+- sword::FTPTransport trans("example.com");
++ sword::CURLFTPTransport CURLFTPTransport("example.com");
+
+ return 0;
+ }
+diff -urN a/src/backend/rendering/centrydisplay.h b/src/backend/rendering/centrydisplay.h
+--- a/src/backend/rendering/centrydisplay.h 2013-06-03 18:08:52.000000000 +0000
++++ b/src/backend/rendering/centrydisplay.h 2014-06-16 14:28:00.972395181 +0000
+@@ -35,6 +35,7 @@
+ const DisplayOptions &displayOptions,
+ const FilterOptions &filterOptions);
+
++ virtual char display(sword::SWModule& mod) { (void)mod; return 'c';}
+ }; /* class CEntryDisplay */
+
+ } /* namespace Rendering */
+diff -urN a/src/bibletime.cpp b/src/bibletime.cpp
+--- a/src/bibletime.cpp 2013-06-03 18:08:52.000000000 +0000
++++ b/src/bibletime.cpp 2014-06-17 09:06:12.656074834 +0000
+@@ -285,7 +285,7 @@
+ const int maxIndex = 31100;
+ int newIndex = rand() % maxIndex;
+ vk.setPosition(sword::TOP);
+- vk.Index(newIndex);
++ vk.setIndex(newIndex);
+ createReadDisplayWindow(bible, vk.key());
+ } else {
+ createReadDisplayWindow(bible, bibleKey);
+diff -urN a/src/frontend/bookshelfmanager/btinstallmgr.cpp b/src/frontend/bookshelfmanager/btinstallmgr.cpp
+--- a/src/frontend/bookshelfmanager/btinstallmgr.cpp 2013-06-03 18:08:52.000000000 +0000
++++ b/src/frontend/bookshelfmanager/btinstallmgr.cpp 2014-06-17 09:55:32.442530952 +0000
+@@ -18,7 +18,7 @@
+
+ // Sword includes:
+ #include <installmgr.h>
+-#include <ftptrans.h>
++#include <curlftpt.h>
+
+
+ using namespace sword;
+diff -urN a/src/frontend/bookshelfmanager/btinstallmgr.h b/src/frontend/bookshelfmanager/btinstallmgr.h
+--- a/src/frontend/bookshelfmanager/btinstallmgr.h 2013-06-03 18:08:52.000000000 +0000
++++ b/src/frontend/bookshelfmanager/btinstallmgr.h 2014-06-17 09:53:52.314448110 +0000
+@@ -18,7 +18,7 @@
+
+ // Sword includes:
+ #include <installmgr.h>
+-#include <ftptrans.h>
++#include <curlftpt.h>
+
+
+ /**
diff --git a/debian/patches/series b/debian/patches/series
index 3b5fb5a..ac6ab7a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
gcc4.7-ftbfs.patch
find-clucene-config.h.diff
+libsword-1.7.patch