summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:40 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:40 -0400
commit00bc0a3de99e088902379dcb2905fb1546c7eca2 (patch)
treed248b25166e49de203f8b85702a8c88af52c0339 /CMakeLists.txt
parentdf8f1d512c60a96f9041f9663b3fdc2db51cba33 (diff)
Imported Upstream version 2.9.1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt80
1 files changed, 42 insertions, 38 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd10916..603f420 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,11 +2,28 @@ PROJECT(bibletime CXX C)
CMAKE_MINIMUM_REQUIRED(VERSION 2.6.2)
SET(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+################################################################################
# BibleTime version
+################################################################################
+# NOTICE! The version number must only be changed during the release procedures
+# A N D N O T during development or bug-fixing. This guarantees that all
+# versions of BibleTime between OLDVERSION and NEXTVERSION have version strings
+# in the form of OLDVERSION+githash where githash is the git commit hash ID.
+#
+# Note: for pre-#.#.0 versions, use the following suffixes:
+# _dev if pre-beta1
+# _beta1 if post-beta1
+# _beta2 if post-beta2
+# _rc1 if post-rc1
+# _rc2 if post-rc2
+# For post-full-release versions, no suffix is used.
+
SET(BT_VERSION_MAJOR "2")
-SET(BT_VERSION_MINOR "8")
+SET(BT_VERSION_MINOR "9")
SET(BT_VERSION_PATCH "1")
-SET(BT_VERSION_BUILD "") # Temporarily uncomment this line for release procedures
+#SET(BT_VERSION_BUILD "") # Temporarily uncomment this line for release procedures
+
# Determine build, if needed:
IF (NOT (DEFINED BT_VERSION_BUILD))
@@ -34,10 +51,10 @@ ELSE (NOT CMAKE_BUILD_TYPE STREQUAL "Release")
ENDIF (NOT CMAKE_BUILD_TYPE STREQUAL "Release")
#Non-English locales to be processed and installed for UI, handbook and howto
-LIST(APPEND MESSAGE_LOCALE_LANGS ar cs da de en_GB es et fi fr hu it nl nn_NO pl pt_BR ro ru sk zh_TW)
+LIST(APPEND MESSAGE_LOCALE_LANGS ar cs da de en_GB es et fi fr hu it nl nn_NO pl pt pt_BR ro ru sk zh_TW)
#WARNING: If you modify HANDBOOK_LOCALE_LANGS or HOWTO_LOCALE_LANGS,
#also modify the po4a conf files in cmake/docs/ to make sure all languages are processed.
-LIST(APPEND HANDBOOK_LOCALE_LANGS cs de es fi fr hu it nl pt_BR)
+LIST(APPEND HANDBOOK_LOCALE_LANGS ar cs de es fi fr hu it nl pt_BR)
LIST(APPEND HOWTO_LOCALE_LANGS ar bg cs da de es fi fr it hu ko nl pt_BR ru)
# Find required packages
@@ -131,45 +148,28 @@ IF (MSVC)
SOURCE_GROUP( "Icon Files"
FILES "cmake/BTWinIcon.rc" }
)
+ ADD_EXECUTABLE(${EXECUTABLE_NAME} WIN32 ${common_bibletime_SOURCES})
+ELSE (MSVC)
+ ADD_EXECUTABLE(${EXECUTABLE_NAME} ${common_bibletime_SOURCES})
ENDIF (MSVC)
-IF (CMAKE_BUILD_TYPE STREQUAL "Release")
- IF (MSVC)
- ADD_EXECUTABLE(${EXECUTABLE_NAME} WIN32 ${common_bibletime_SOURCES})
- ELSE (MSVC)
- ADD_EXECUTABLE(${EXECUTABLE_NAME} ${common_bibletime_SOURCES})
- ENDIF (MSVC)
+#IF (CMAKE_BUILD_TYPE STREQUAL "Release")
# SET_TARGET_PROPERTIES(${EXECUTABLE_NAME}
# PROPERTIES
# COMPILE_FLAGS "${SWORD_CFLAGS}" #Enable exception handling
# )
- INCLUDE(${QT_USE_FILE})
- TARGET_LINK_LIBRARIES(${EXECUTABLE_NAME}
- ${QT_LIBRARIES}
- ${CLUCENE_LIBRARY}
- ${CURL_LIBRARIES} # optional, empty if not found
- ${ICU_LIBRARIES} # optional, empty if not found
- ${ICU_I18N_LIBRARIES} # optional, empty if not found
- ${ZLIB_LIBRARIES} # optional, empty if not found
- ${SWORD_LIBRARY}
- )
-ELSE (CMAKE_BUILD_TYPE STREQUAL "Release")
- IF (MSVC)
- ADD_EXECUTABLE(${EXECUTABLE_NAME} WIN32 ${common_bibletime_SOURCES})
- ELSE (MSVC)
- ADD_EXECUTABLE(${EXECUTABLE_NAME} ${common_bibletime_SOURCES})
- ENDIF (MSVC)
- INCLUDE(${QT_USE_FILE})
- TARGET_LINK_LIBRARIES(${EXECUTABLE_NAME}
- ${QT_LIBRARIES}
- ${CLUCENE_LIBRARY}
- ${CURL_LIBRARIES} # optional, empty if not found
- ${ICU_LIBRARIES} # optional, empty if not found
- ${ICU_I18N_LIBRARIES} # optional, empty if not found
- ${ZLIB_LIBRARIES} # optional, empty if not found
- ${SWORD_LIBRARY}
- )
-ENDIF (CMAKE_BUILD_TYPE STREQUAL "Release")
+#ENDIF (CMAKE_BUILD_TYPE STREQUAL "Release")
+
+INCLUDE(${QT_USE_FILE})
+TARGET_LINK_LIBRARIES(${EXECUTABLE_NAME}
+ ${QT_LIBRARIES}
+ ${CLUCENE_LIBRARY}
+ ${CURL_LIBRARIES} # optional, empty if not found
+ ${ICU_LIBRARIES} # optional, empty if not found
+ ${ICU_I18N_LIBRARIES} # optional, empty if not found
+ ${ZLIB_LIBRARIES} # optional, empty if not found
+ ${SWORD_LIBRARY}
+)
IF (APPLE)
# enable support MacOS 10.5+
@@ -220,6 +220,10 @@ FILE(GLOB INSTALL_DISPLAY_TEMPLATES_LIST ${CMAKE_CURRENT_SOURCE_DIR}/src/display
INSTALL(FILES ${INSTALL_DISPLAY_TEMPLATES_LIST}
DESTINATION "${BT_SHARE_PATH}bibletime/display-templates/"
)
+FILE(GLOB INSTALL_DISPLAY_CSS_LIST ${CMAKE_CURRENT_SOURCE_DIR}/src/display-templates/*.css)
+INSTALL(FILES ${INSTALL_DISPLAY_CSS_LIST}
+ DESTINATION "${BT_SHARE_PATH}bibletime/display-templates/"
+)
# javascript
INSTALL(FILES "src/frontend/display/bthtml.js"
DESTINATION "${BT_SHARE_PATH}bibletime/javascript/"
@@ -229,7 +233,7 @@ INSTALL(FILES "docs/license.html"
DESTINATION "${BT_SHARE_PATH}bibletime/license/"
)
# splash screen
-INSTALL(FILES "pics/startuplogo.png" "pics/startuplogo_christmas.png"
+INSTALL(FILES "pics/startuplogo.png" "pics/startuplogo_christmas.png" "pics/startuplogo_easter.jpg"
DESTINATION "${BT_SHARE_PATH}bibletime/pics/"
)
#