summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJonathan Marsden <jmarsden@fastmail.fm>2009-06-02 23:37:30 -0700
committerRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:23 -0400
commit1d60d8274f0cd935798c4ae1146bf70b70134d85 (patch)
tree446feda635ff30256cbe755a2d80f095f9994995 /debian
parent49e1233d7ae1e73999dabe5be77a4ded916b49da (diff)
parentcbb6dcfb002dd5bc5f702a4909306be5c2878319 (diff)
Imported Debian patch 2.0-1
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source35
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rw-r--r--debian/patches/01_main_window_icon.diff60
-rw-r--r--debian/patches/02_remove_unwanted_debug_code.diff32
5 files changed, 135 insertions, 4 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..85880c2
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,35 @@
+This package uses CDBS (and therefore simple-patchsys.mk) in order to
+apply patches to the upstream source. Patches are stored in
+debian/patches and their filenames usually end in .patch or .diff .
+For further details, see the man page for cdbs-edit-patch.
+
+All commands described below should be run from the top directory of the
+package source tree, unless otherwise stated.
+
+ * To generate the fully patched source, in a form ready for
+ editing, that would be built to create Debian packages, run:
+
+ make -f debian/rules apply-patches
+
+ Note: It has been proposed that, in future, this should happen
+ automatically when you run dpkg-source -x on a CDBS
+ simple-patchsys.mk source package. However, this proposal has
+ apparently not yet been implemented, so for now you have to do
+ it yourself like this.
+
+ * To modify the source and save those modifications so that
+ they will be applied when building the package, pick a
+ suitably informative patch file name, for example
+ 01_add_README.source_file.patch, and then run:
+
+ cdbs-edit-patch 01_add_README.source_file.patch
+
+ This will place you in a new shell in a temporary copy of the
+ source tree. Make your desired modifications to it, and then
+ exit the shell to create the patch file containing them (this
+ file will appear in debian/patches).
+
+ * To remove source modifications that are currently being
+ applied when building the package, run:
+
+ make -f debian/rules reverse-patches
diff --git a/debian/changelog b/debian/changelog
index 025e48c..f882eb3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,14 @@
-bibletime (2.0~beta2-1) experimental; urgency=low
+bibletime (2.0-1) unstable; urgency=low
* New upstream version.
* debian/rules:
- Ensure installation of manpages and .xpm work once again.
* Remove debian/dirs, debian/install and other files from debian/
* Remove debian/patches/00-fix-desktop.patch -- upstream fixed this.
+ * Add debian/patches/01_main_window_icon.diff
+ - upstream svn r1317.
+ * Add debian/patches/02_remove_unwanted_debug_code.diff
+ - upstream svn r1318.
* Add debian/watch file.
* debian/rules: use cdbs cmake.mk not kde4.mk
* debian/control: Remove Build-depend on pkg-kde-tools.
@@ -24,7 +28,7 @@ bibletime (2.0~beta2-1) experimental; urgency=low
- Update copyright year range.
- Update download location.
- -- Jonathan Marsden <jmarsden@fastmail.fm> Sat, 02 May 2009 21:25:01 -0700
+ -- Jonathan Marsden <jmarsden@fastmail.fm> Tue, 02 Jun 2009 23:37:30 -0700
bibletime (1.6.5.1-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 0229b31..ac3a7b8 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,8 @@
Source: bibletime
Section: kde
Build-Depends: bzip2, autotools-dev, quilt, patchutils (>= 0.2.25),
- cdbs (>= 0.4.27), debhelper (>= 7), libsword-dev (>= 1.5.11),
- libqt4-dev, libclucene-dev, poxml, libboost-dev, cmake, pkg-config
+ cdbs (>= 0.4.27), debhelper (>= 7), libsword-dev (> 1.5.11),
+ libqt4-dev (>= 4.4.0), libclucene-dev, poxml, libboost-dev, cmake, pkg-config
Priority: optional
Maintainer: CrossWire Packages <pkg-crosswire-devel@lists.alioth.debian.org>
Uploaders: Daniel Glassey <wdg@debian.org>,
diff --git a/debian/patches/01_main_window_icon.diff b/debian/patches/01_main_window_icon.diff
new file mode 100644
index 0000000..d820e3c
--- /dev/null
+++ b/debian/patches/01_main_window_icon.diff
@@ -0,0 +1,60 @@
+Associate an icon with the main window. Upstream svn r1317.
+Index: ChangeLog
+===================================================================
+--- old/ChangeLog (revision 1316)
++++ new/ChangeLog (working copy)
+@@ -1,3 +1,6 @@
++2009-05-30 Gary Holmlund
++ * Fix defect, the main window icon was missing - defect # 2798758
++
+ 2009-05-28 Martin Gruner <mgruner@crosswire.org>
+ * release 2.0
+
+Index: src/bibletime.cpp
+===================================================================
+--- old/src/bibletime.cpp (revision 1316)
++++ new/src/bibletime.cpp (working copy)
+@@ -20,6 +20,7 @@
+
+ #include "util/ctoolclass.h"
+ #include "util/cpointers.h"
++#include "util/cresmgr.h"
+ #include "util/directoryutil.h"
+
+ #include "backend/drivers/cswordmoduleinfo.h"
+@@ -75,6 +76,7 @@
+ initConnections();
+ readSettings();
+ setPlainCaption(QString());
++ setWindowIcon( util::filesystem::DirectoryUtil::getIcon(CResMgr::mainWindow::icon) );
+ }
+
+ BibleTime::~BibleTime()
+Index: src/util/cresmgr.cpp
+===================================================================
+--- old/src/util/cresmgr.cpp (revision 1316)
++++ new/src/util/cresmgr.cpp (working copy)
+@@ -13,6 +13,9 @@
+
+
+ namespace CResMgr {
++ namespace mainWindow {
++ const QString icon = "bibletime.svg";
++ } // mainWindow
+ namespace modules {
+ namespace bible {
+ const QString icon_unlocked = "bible.svg";
+Index: src/util/cresmgr.h
+===================================================================
+--- old/src/util/cresmgr.h (revision 1316)
++++ new/src/util/cresmgr.h (working copy)
+@@ -20,6 +20,9 @@
+ namespace CResMgr {
+ void init_tr();
+
++ namespace mainWindow {
++ extern const QString icon;
++ }
+ namespace modules {
+ namespace bible {
+ extern const QString icon_unlocked;
diff --git a/debian/patches/02_remove_unwanted_debug_code.diff b/debian/patches/02_remove_unwanted_debug_code.diff
new file mode 100644
index 0000000..6028711
--- /dev/null
+++ b/debian/patches/02_remove_unwanted_debug_code.diff
@@ -0,0 +1,32 @@
+Remove unwanted debug code that created ./out.txt. Upstream svn r1318.
+Index: src/frontend/display/bthtmlreaddisplay.cpp
+===================================================================
+--- src/frontend/display/bthtmlreaddisplay.cpp (revision 1317)
++++ src/frontend/display/bthtmlreaddisplay.cpp (working copy)
+@@ -213,19 +213,11 @@
+ return QString();
+ }
+
+-#include <QTextStream>
+ // Puts html text and javascript into QWebView
+ void BtHtmlReadDisplay::setText( const QString& newText )
+ {
+ QString jsText = newText;
+
+- QFile file("out.txt");
+- if (!file.open(QIODevice::WriteOnly | QIODevice::Text))
+- return;
+-
+- QTextStream out(&file);
+- out << newText << "\n";
+-
+ jsText.replace(body,jsBegin+javascript+jsEnd+body);
+
+ // Disconnect any previous connect and connect to slot that loads the javascript object
+@@ -379,4 +371,4 @@
+ if ( e->type() == QEvent::Leave )
+ m_display->m_jsObject->clearPrevAttribute();
+ return QWidget::event(e);
+-}
+\ No newline at end of file
++}