summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/README.source35
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
4 files changed, 8 insertions, 38 deletions
diff --git a/debian/README.source b/debian/README.source
deleted file mode 100644
index 85880c2..0000000
--- a/debian/README.source
+++ /dev/null
@@ -1,35 +0,0 @@
-This package uses CDBS (and therefore simple-patchsys.mk) in order to
-apply patches to the upstream source. Patches are stored in
-debian/patches and their filenames usually end in .patch or .diff .
-For further details, see the man page for cdbs-edit-patch.
-
-All commands described below should be run from the top directory of the
-package source tree, unless otherwise stated.
-
- * To generate the fully patched source, in a form ready for
- editing, that would be built to create Debian packages, run:
-
- make -f debian/rules apply-patches
-
- Note: It has been proposed that, in future, this should happen
- automatically when you run dpkg-source -x on a CDBS
- simple-patchsys.mk source package. However, this proposal has
- apparently not yet been implemented, so for now you have to do
- it yourself like this.
-
- * To modify the source and save those modifications so that
- they will be applied when building the package, pick a
- suitably informative patch file name, for example
- 01_add_README.source_file.patch, and then run:
-
- cdbs-edit-patch 01_add_README.source_file.patch
-
- This will place you in a new shell in a temporary copy of the
- source tree. Make your desired modifications to it, and then
- exit the shell to create the patch file containing them (this
- file will appear in debian/patches).
-
- * To remove source modifications that are currently being
- applied when building the package, run:
-
- make -f debian/rules reverse-patches
diff --git a/debian/changelog b/debian/changelog
index 15f16f2..69492b4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
-bibletime (2.11.2-7) experimental; urgency=medium
+bibletime (2.11.2-7) UNRELEASED; urgency=medium
+ [ Teus Benschop ]
* d/control: depends on libsword 1.8.1-6 or higher
+ [ Daniel Glassey ]
+ * d/README.source remove, not using cdbs any more
+ * d/compat, control update to debhelper 11
+
-- Teus Benschop <teusjannette@gmail.com> Tue, 06 Nov 2018 17:32:23 +0100
bibletime (2.11.2-6) unstable; urgency=high
diff --git a/debian/compat b/debian/compat
index ec63514..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+11
diff --git a/debian/control b/debian/control
index aabf1e4..1b62c5c 100644
--- a/debian/control
+++ b/debian/control
@@ -1,6 +1,6 @@
Source: bibletime
Section: kde
-Build-Depends: quilt (>= 0.46-7~), debhelper (>= 9),
+Build-Depends: quilt (>= 0.46-7~), debhelper (>= 11),
libsword-dev (>= 1.8.1-6), libclucene-dev, cmake,
pkg-config, libcurl4-gnutls-dev, git,
qtbase5-dev, qttools5-dev, qtwebengine5-dev, libqt5svg5-dev