summaryrefslogtreecommitdiff
path: root/bibletime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bibletime/Makefile.am')
-rw-r--r--bibletime/Makefile.am80
1 files changed, 80 insertions, 0 deletions
diff --git a/bibletime/Makefile.am b/bibletime/Makefile.am
new file mode 100644
index 0000000..ecb8124
--- /dev/null
+++ b/bibletime/Makefile.am
@@ -0,0 +1,80 @@
+bibletime_SOURCES = \
+bibletime_init.cpp \
+bibletime_slots.cpp \
+bibletime.cpp \
+main.cpp
+
+bibletime_LDADD = \
+./printing/libprinting.a \
+./frontend/presenters/libpresenters.a \
+./frontend/keychooser/libkeychooser.a \
+./frontend/groupmanager/libgroupmanager.a \
+./frontend/searchdialog/libsearchdialog.a \
+./frontend/libfrontend.a \
+./frontend/thirdparty/qt3stuff/libqt3stuff.a \
+./frontend/thirdparty/libthirdparty.a \
+./backend/libbackend.a \
+-lXext \
+$(LIB_QT) \
+$(LIB_KDECORE) \
+$(LIB_KDEUI) \
+-lkdeprint \
+$(LIB_KFILE) \
+$(LIB_X11) \
+$(LIB_SWORD) \
+$(LIBSOCKET)
+
+SUBDIRS = backend printing frontend xml pics util
+
+all_headers = bibletime.h \
+resource.h \
+whatsthisdef.h \
+tooltipdef.h \
+bt-printing
+
+EXTRA_DIST = $(bibletime_SOURCES) $(all_headers)
+
+# this 10 paths are KDE specific. Use them:
+# kde_htmldir Where your docs should go to. (contains lang subdirs)
+# kde_appsdir Where your application file (.kdelnk) should go to.
+# kde_icondir Where your icon should go to.
+# kde_minidir Where your mini icon should go to.
+# kde_datadir Where you install application data. (Use a subdir)
+# kde_locale Where translation files should go to.(contains lang subdirs)
+# kde_cgidir Where cgi-bin executables should go to.
+# kde_confdir Where config files should go to.
+# kde_mimedir Where mimetypes should go to.
+# kde_toolbardir Where general toolbar icons should go to.
+# kde_wallpaperdir Where general wallpapers should go to.
+
+# set the include path for X, qt, KDE and Sword
+INCLUDES = $(all_includes)
+
+# claim, which subdirectories you want to install
+# you can add here more. This one gets installed
+bin_PROGRAMS = bibletime
+
+bibletime_METASOURCES = AUTO
+
+# the library search path.
+bibletime_LDFLAGS = $(BT_LDFLAGS) $(all_libraries) $(KDE_RPATH)
+
+# them while "make clean", use CLEANFILES
+DISTCLEANFILES = $(bibletime_METASOURCES)
+
+# make messages.po. Move this one to ../po/ and "make merge" in po
+# the -x is for skipping messages already translated in kdelibs
+#messages:
+# $(XGETTEXT) -C -ki18n -x $(KDEDIR)/include/kde.pot `find . -name \*.h -o -name \*.cpp -o -name \*.cc` -o ../po/bibletime.pot
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(kde_confdir)
+ $(INSTALL_DATA) bt-printing $(DESTDIR)$(kde_confdir)/bt-printing
+
+uninstall-local:
+ -rm -f $(DESTDIR)$(kde_confdir)/bt-printing
+
+rpm: dist
+
+
+