summaryrefslogtreecommitdiff
path: root/debian/patches/gcc4.7-ftbfs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/gcc4.7-ftbfs.patch')
-rw-r--r--debian/patches/gcc4.7-ftbfs.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/gcc4.7-ftbfs.patch b/debian/patches/gcc4.7-ftbfs.patch
new file mode 100644
index 0000000..750381e
--- /dev/null
+++ b/debian/patches/gcc4.7-ftbfs.patch
@@ -0,0 +1,16 @@
+Description: Work-around FTBFS with gcc4.7 by disabling -Werror
+Author: Dmitrijs Ledkovs <xnox@debian.org>
+
+Index: bibletime/CMakeLists.txt
+===================================================================
+--- bibletime.orig/CMakeLists.txt 2012-04-14 17:26:58.958854000 +0100
++++ bibletime/CMakeLists.txt 2012-04-17 22:38:01.936487437 +0100
+@@ -194,7 +194,7 @@
+ SET(CMAKE_CXX_FLAGS_DEBUG "-DNO_DBUS -DSWUSINGDLL /MDd /Zc:wchar_t- /W1 /D_UNICODE /DUNICODE /ZI")
+ ELSE (MSVC)
+ SET(CMAKE_CXX_FLAGS_RELEASE "-Wall -O2 -fexceptions")
+- SET(CMAKE_CXX_FLAGS_DEBUG "-Wall -Werror -O2 -ggdb -fexceptions")
++ SET(CMAKE_CXX_FLAGS_DEBUG "-Wall -O2 -ggdb -fexceptions")
+ ENDIF (MSVC)
+
+