summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2016-08-03 13:20:51 +0200
committerStephane Glondu <steph@glondu.net>2016-08-03 13:20:51 +0200
commit04c490a2c02e76694cd886b5dd86cf892c892869 (patch)
tree21b271600f25e32e36af4b2d82d281df3ef828ab
parent9d70b84006698a2026782917396b428a767589b9 (diff)
Imported Upstream version 1.0.11
-rw-r--r--.gitignore3
-rw-r--r--Makefile21
2 files changed, 21 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 2ff1963..76fa4f8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,4 +8,7 @@ META
bdump
test-stream.dat
test2.bin
+*.byte
+*.native
+*.exe
test_biniou
diff --git a/Makefile b/Makefile
index 93681b9..aae8631 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-VERSION = 1.0.10
+VERSION = 1.0.11
FLAGS = -g -annot -bin-annot
PACKS = easy-format
@@ -9,8 +9,21 @@ else
EXE=
endif
-BEST != if ocamlfind ocamlopt 2>/dev/null; then echo .native; else echo .byte; fi
-NATDYNLINK != if [ -f `ocamlfind ocamlc -where`/dynlink.cmxa ]; then echo YES; else echo NO; fi
+BEST = $(shell \
+ if ocamlfind ocamlopt 2>/dev/null; then \
+ echo .native; \
+ else \
+ echo .byte; \
+ fi \
+)
+
+NATDYNLINK = $(shell \
+ if [ -f `ocamlfind ocamlc -where`/dynlink.cmxa ]; then \
+ echo YES; \
+ else \
+ echo NO; \
+ fi \
+)
ifeq "${NATDYNLINK}" "YES"
CMXS=biniou.cmxs
@@ -18,11 +31,13 @@ endif
.PHONY: default all byte opt install doc test
default: all test_biniou$(EXE)
+
ifeq "$(BEST)" ".native"
all: byte opt doc META
else
all: byte doc META
endif
+
byte: biniou.cma bdump.byte
opt: biniou.cmxa $(CMXS) bdump.native