summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2019-12-17 16:52:51 +0100
committerStéphane Glondu <steph@glondu.net>2019-12-17 16:52:51 +0100
commit48d0c9bec177c33f62ed79abed337648c03fd6e4 (patch)
tree936abdb67e19d0304f31aac380c0d0aaa0f41f88
parentae6decf5f7dcccf531a5689036eb8dd66c44bd76 (diff)
parent205942b4937e5fec6ea41241416f5f88ebe126c7 (diff)
Update upstream source from tag 'upstream/1.2.1'
Update to upstream version '1.2.1' with Debian dir b08fa083effe930327d23525721832d7a048ba96
-rw-r--r--CHANGES.md38
-rw-r--r--Changes27
-rw-r--r--Makefile14
-rw-r--r--README.md4
-rw-r--r--bin/dune6
-rw-r--r--bin/jbuild8
-rw-r--r--biniou.opam44
-rw-r--r--dune-project34
-rw-r--r--src/dune7
-rw-r--r--src/jbuild9
-rw-r--r--test/dune11
-rw-r--r--test/jbuild11
12 files changed, 139 insertions, 74 deletions
diff --git a/CHANGES.md b/CHANGES.md
new file mode 100644
index 0000000..2763f96
--- /dev/null
+++ b/CHANGES.md
@@ -0,0 +1,38 @@
+1.2.1 (2019-08-02)
+------------------
+
+- Remove which dependency (#25)
+- Migrate to dune (#29)
+- Generate opam file from dune and port to opam 2.0 (#30)
+
+1.0.2 (2012-03-19)
+------------------
+
+- support for flushing output to abstract OO channels
+
+1.0.1 (2012-01-03)
+------------------
+
+- new experimental array streaming utility
+- compiling with -g, allowing stack trace recording
+- fixed description of the format for string encoding
+
+1.0.0 (2010-12-04)
+------------------
+
+- added system of references for sharing values
+- new variant `Shared
+- new fields in input and output buffers
+- bdump: option -h to specify alternate dictionary
+- standalone reference for the biniou format
+
+0.9.1 (2010-09-13)
+------------------
+
+- fixed Bi_inbuf.from_channel
+- added INSTALL file
+
+0.9.0 (2010-08-04)
+------------------
+
+- first release
diff --git a/Changes b/Changes
deleted file mode 100644
index 60d9830..0000000
--- a/Changes
+++ /dev/null
@@ -1,27 +0,0 @@
-Releases of biniou
-==================
-
-!!! = some incompatibilities
-opt = optimizations
-+ui = additions in the user interface
--ui = restrictions in the user interface
-bug = bug or security fix
-doc = major changes in the documentation
-pkg = changes in the structure of the package or in the installation procedure
-
-2012-03-19 1.0.2: [+ui] support for flushing output to abstract OO channels
-
-2012-01-03 1.0.1: [+ui] new experimental array streaming utility
- [+ui] compiling with -g, allowing stack trace recording
- [doc] fixed description of the format for string encoding
-
-2010-12-04 1.0.0: [+ui] added system of references for sharing values
- [!!!] new variant `Shared
- [!!!] new fields in input and output buffers
- [+ui] bdump: option -h to specify alternate dictionary
- [pkg] standalone reference for the biniou format
-
-2010-09-13 0.9.1: [bug] fixed Bi_inbuf.from_channel
- [pkg] added INSTALL file
-
-2010-08-04 0.9.0: first release
diff --git a/Makefile b/Makefile
index 9fd3612..d57c8d0 100644
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,18 @@
all:
- @jbuilder build
+ dune build
test:
- @jbuilder runtest
+ dune runtest
check: test
-.PHONY: clean all check test
+install:
+ dune install
+
+uninstall:
+ dune uninstall
+
+.PHONY: clean all check test install uninstall
clean:
- jbuilder clean
+ dune clean
diff --git a/README.md b/README.md
index 193adc8..43ee631 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,7 @@
+**This project is unmaintained. Pull requests won't be reviewed.
+ If you would like to contribute, please request a transfer to
+ [ocaml-community](https://github.com/ocaml-community/meta).**
+
Biniou
======
diff --git a/bin/dune b/bin/dune
new file mode 100644
index 0000000..8ae7647
--- /dev/null
+++ b/bin/dune
@@ -0,0 +1,6 @@
+(executable
+ (name bdump)
+ (public_name bdump)
+ (package biniou)
+ (flags -safe-string)
+ (libraries biniou))
diff --git a/bin/jbuild b/bin/jbuild
deleted file mode 100644
index 98962f1..0000000
--- a/bin/jbuild
+++ /dev/null
@@ -1,8 +0,0 @@
-(jbuild_version 1)
-
-(executable
- ((name bdump)
- (public_name bdump)
- (package biniou)
- (flags (-safe-string))
- (libraries (biniou))))
diff --git a/biniou.opam b/biniou.opam
index 037005d..9b4ce15 100644
--- a/biniou.opam
+++ b/biniou.opam
@@ -1,24 +1,38 @@
-opam-version: "1.2"
-maintainer: "martin@mjambon.com"
+# This file is generated by dune, edit dune-project instead
+opam-version: "2.0"
+build: [
+ ["dune" "subst"] {pinned}
+ ["dune" "build" "-p" name "-j" jobs]
+ ["dune" "runtest" "-p" name "-j" jobs] {with-test}
+ ["dune" "build" "-p" name "@doc"] {with-doc}
+]
+maintainer: ["martin@mjambon.com"]
authors: ["Martin Jambon"]
-
-homepage: "https://github.com/mjambon/biniou"
bug-reports: "https://github.com/mjambon/biniou/issues"
-dev-repo: "https://github.com/mjambon/biniou.git"
+homepage: "https://github.com/mjambon/biniou"
+doc: "https://mjambon.github.io/biniou/"
license: "BSD-3-Clause"
+dev-repo: "git+https://github.com/mjambon/biniou.git"
+synopsis:
+ "Binary data format designed for speed, safety, ease of use and backward compatibility as protocols evolve"
+description: """
-build: [
- ["jbuilder" "build" "-p" name "-j" jobs]
-]
+Biniou (pronounced "be new") is a binary data format designed for speed, safety,
+ease of use and backward compatibility as protocols evolve. Biniou is vastly
+equivalent to JSON in terms of functionality but allows implementations several
+times faster (4 times faster than yojson), with 25-35% space savings.
-build-test: [
- ["jbuilder" "runtest" "-p" name]
-]
+Biniou data can be decoded into human-readable form without knowledge of type
+definitions except for field and variant names which are represented by 31-bit
+hashes. A program named bdump is provided for routine visualization of biniou
+data files.
+The program atdgen is used to derive OCaml-Biniou serializers and deserializers
+from type definitions.
+
+Biniou format specification: mjambon.github.io/atdgen-doc/biniou-format.txt"""
depends: [
- "conf-which" {build}
- "jbuilder" {build}
"easy-format"
+ "dune" {>= "1.10"}
+ "ocaml" {>= "4.02.3"}
]
-
-available: [ocaml-version >= "4.02.3"] \ No newline at end of file
diff --git a/dune-project b/dune-project
new file mode 100644
index 0000000..21e23fc
--- /dev/null
+++ b/dune-project
@@ -0,0 +1,34 @@
+(lang dune 1.10)
+(name biniou)
+
+(generate_opam_files true)
+(license "BSD-3-Clause")
+(maintainers "martin@mjambon.com")
+(authors "Martin Jambon")
+(implicit_transitive_deps false)
+(source (github mjambon/biniou))
+(documentation "https://mjambon.github.io/biniou/")
+
+(package
+ (name biniou)
+ (synopsis
+ "Binary data format designed for speed, safety, ease of use and backward compatibility as protocols evolve")
+ (description "
+Biniou (pronounced \"be new\") is a binary data format designed for speed, safety,
+ease of use and backward compatibility as protocols evolve. Biniou is vastly
+equivalent to JSON in terms of functionality but allows implementations several
+times faster (4 times faster than yojson), with 25-35% space savings.
+
+Biniou data can be decoded into human-readable form without knowledge of type
+definitions except for field and variant names which are represented by 31-bit
+hashes. A program named bdump is provided for routine visualization of biniou
+data files.
+
+The program atdgen is used to derive OCaml-Biniou serializers and deserializers
+from type definitions.
+
+Biniou format specification: mjambon.github.io/atdgen-doc/biniou-format.txt")
+ (depends
+ easy-format
+ (dune (>= 1.10))
+ (ocaml (>= "4.02.3"))))
diff --git a/src/dune b/src/dune
new file mode 100644
index 0000000..03b18e1
--- /dev/null
+++ b/src/dune
@@ -0,0 +1,7 @@
+(library
+ (name biniou)
+ (public_name biniou)
+ (synopsis "Extensible binary serialization format")
+ (wrapped false)
+ (flags -safe-string)
+ (libraries easy-format))
diff --git a/src/jbuild b/src/jbuild
deleted file mode 100644
index 153a346..0000000
--- a/src/jbuild
+++ /dev/null
@@ -1,9 +0,0 @@
-(jbuild_version 1)
-
-(library
- ((name biniou)
- (public_name biniou)
- (synopsis "Extensible binary serialization format")
- (wrapped false)
- (flags (-safe-string))
- (libraries (easy-format))))
diff --git a/test/dune b/test/dune
new file mode 100644
index 0000000..ac021e9
--- /dev/null
+++ b/test/dune
@@ -0,0 +1,11 @@
+(executable
+ (name test_biniou)
+ (flags -safe-string)
+ (libraries biniou unix))
+
+(alias
+ (name runtest)
+ (deps
+ (:< test_biniou.exe))
+ (action
+ (run %{<})))
diff --git a/test/jbuild b/test/jbuild
deleted file mode 100644
index 3ca83c9..0000000
--- a/test/jbuild
+++ /dev/null
@@ -1,11 +0,0 @@
-(jbuild_version 1)
-
-(executable
- ((name test_biniou)
- (flags (-safe-string))
- (libraries (biniou unix))))
-
-(alias
- ((name runtest)
- (deps (test_biniou.exe))
- (action (run ${<}))))