summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-09-25 13:46:49 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-10-02 13:50:35 +0200
commitb48df83bf02183ff87063e9cf27459940c489c94 (patch)
treed1394aa4ad7ad8baa3e16ae91d59fa9a435b0008
parentac30a0b51940a20fc911a30e13ee449fd050e56d (diff)
switch Debian packages to python3
-rw-r--r--debian/control31
-rw-r--r--debian/python-binoculars-doc.docs2
-rwxr-xr-xdebian/rules20
3 files changed, 23 insertions, 30 deletions
diff --git a/debian/control b/debian/control
index 8c40b67..3eda607 100644
--- a/debian/control
+++ b/debian/control
@@ -6,10 +6,11 @@ Priority: extra
Build-Depends: debhelper (>= 9),
dh-python,
gir1.2-hkl-5.0,
- python3-numpy,
- python3-all-dev,
- python3-pyfai,
- python3-sphinx,
+ python3-all,
+ python3-numpy,
+ python3-pyfai,
+ python3-setuptools,
+ python3-sphinx
Standards-Version: 4.1.2
Vcs-Browser: https://anonscm.debian.org/cgit/debian-science/packages/binoculars.git
Vcs-Git: git://anonscm.debian.org/debian-science/packages/binoculars.git
@@ -17,10 +18,10 @@ Homepage: https://github.com/id03/binoculars
Package: binoculars
Architecture: all
-Depends: ${misc:Depends},
+Depends: python3-binoculars (>= ${source:Version}),
+ ${misc:Depends},
${python:Depends},
- ${shlibs:Depends},
- python3-binoculars (>= ${source:Version})
+ ${shlibs:Depends}
Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction
BINoculars is a tool for data reduction and analysis of large sets of
surface diffraction data that have been acquired with a
@@ -38,16 +39,7 @@ Description: Data reduction and analysis software for two-dimensional detectors
Package: python3-binoculars
Architecture: all
Section: python
-Depends: ${misc:Depends},
- ${python:Depends},
- ${shlibs:Depends},
- gir1.2-hkl-5.0,
- python3-h5py,
- python3-matplotlib,
- python3-pyfai,
- pymca,
- python3-pyqt5,
- python3-scipy,
+Depends: gir1.2-hkl-5.0, ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
Suggests: python-xrayutilities
Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction - Python3
BINoculars is a tool for data reduction and analysis of large sets of
@@ -65,11 +57,10 @@ Description: Data reduction and analysis software for two-dimensional detectors
.
This is the Python 3 version of the package.
-Package: python-binoculars-doc
+Package: binoculars-doc
Architecture: all
Section: doc
-Depends: ${misc:Depends},
- ${sphinxdoc:Depends},
+Depends: ${misc:Depends}, ${sphinxdoc:Depends}
Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction - Documentation
BINoculars is a tool for data reduction and analysis of large sets of
surface diffraction data that have been acquired with a
diff --git a/debian/python-binoculars-doc.docs b/debian/python-binoculars-doc.docs
index b2dbf19..6d28621 100644
--- a/debian/python-binoculars-doc.docs
+++ b/debian/python-binoculars-doc.docs
@@ -1 +1 @@
-build/html \ No newline at end of file
+build/html
diff --git a/debian/rules b/debian/rules
index 16b7524..0921d86 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,19 +1,21 @@
#!/usr/bin/make -f
export PYBUILD_NAME=binoculars
+export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
%:
dh $@ --with python2,sphinxdoc --buildsystem=pybuild
-override_dh_auto_build:
- dh_auto_build
- PYTHONPATH=. http_proxy='127.0.0.1:9' sphinx-build -N -bhtml doc/source build/html # HTML generator
-
override_dh_install:
- dh_numpy
+ dh_numpy3
dh_install
-# move the scripts into fabio-viewer
- dh_install -p binoculars debian/python-binoculars/usr/bin usr/
-# remove all scripts installed by pybuild
- rm -rf debian/python-binoculars/usr/bin
+ # install scripts into binoculars
+ python setup.py install_scripts -d debian/binoculars/usr/bin
+
+
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=. http_proxy='127.0.0.1:9' sphinx-build -N -bhtml doc/source build/html # HTML generator
+endif
+ dh_sphinxdoc -O--buildsystem=pybuild