summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-10-02 11:19:41 +0200
committerPicca Frédéric-Emmanuel <picca@synchrotron-soleil.fr>2018-10-02 14:05:54 +0200
commitf58bd7c3ab3bd5c81d9b0a8ffc3841dd482a04eb (patch)
treec96391ee802e71cccf6ff62cdefb288f2f61fe4d
parenta433c01b28d8586bc7f429a540dbd7c9226c7fb6 (diff)
-rw-r--r--binoculars/backends/io7.py4
-rw-r--r--debian/changelog4
-rw-r--r--debian/control24
-rw-r--r--debian/copyright2
-rw-r--r--debian/py3dist-overrides1
-rw-r--r--debian/python-binoculars-doc.docs1
-rwxr-xr-xdebian/rules9
-rw-r--r--setup.py6
8 files changed, 29 insertions, 22 deletions
diff --git a/binoculars/backends/io7.py b/binoculars/backends/io7.py
index e239712..71f7e10 100644
--- a/binoculars/backends/io7.py
+++ b/binoculars/backends/io7.py
@@ -229,8 +229,8 @@ class IO7Input(backend.InputBase):
def get_scan(self, scanno):
filename = os.path.join(self.config.datafilefolder, str(scanno) + '.dat')
if not os.path.exists(filename):
- raise errors.ConfigError('datafile filename does not exist: {0}'.format(filename))
- return dnp.io.load(filename)
+ raise errors.ConfigError('datafile filename does not exist: {0}'.format(filename))
+ return dnp.io.load(filename)
@staticmethod
def apply_mask(data, xmask, ymask):
diff --git a/debian/changelog b/debian/changelog
index 261f20c..4f29704 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
-binoculars (0.0.1) unstable; urgency=medium
+binoculars (0.0.2-1) unstable; urgency=medium
- * Initial release (Closes: #656633)
+ * Initial release (Closes: #910077)
-- Picca Frédéric-Emmanuel <picca@debian.org> Wed, 25 Nov 2015 14:25:10 +0200 \ No newline at end of file
diff --git a/debian/control b/debian/control
index 3eda607..f3eb670 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: binoculars
Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Uploaders: Picca Frédéric-Emmanuel <picca@debian.org>
Section: science
-Priority: extra
+Priority: optional
Build-Depends: debhelper (>= 9),
dh-python,
gir1.2-hkl-5.0,
@@ -10,19 +10,20 @@ Build-Depends: debhelper (>= 9),
python3-numpy,
python3-pyfai,
python3-setuptools,
- python3-sphinx
+ python3-sphinx,
+ python3-tables,
Standards-Version: 4.1.2
-Vcs-Browser: https://anonscm.debian.org/cgit/debian-science/packages/binoculars.git
-Vcs-Git: git://anonscm.debian.org/debian-science/packages/binoculars.git
+Vcs-Browser: https://salsa.debian.org/science-team/binoculars
+Vcs-Git: https://salsa.debian.org/science-team/binoculars.git
Homepage: https://github.com/id03/binoculars
Package: binoculars
Architecture: all
+Section: python
Depends: python3-binoculars (>= ${source:Version}),
${misc:Depends},
- ${python:Depends},
- ${shlibs:Depends}
-Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction
+ ${python3:Depends}
+Description: Surface X-ray diffraction 2D detector data reduction
BINoculars is a tool for data reduction and analysis of large sets of
surface diffraction data that have been acquired with a
two-dimensional X-ray detector. The intensity of each pixel of a
@@ -39,9 +40,9 @@ Description: Data reduction and analysis software for two-dimensional detectors
Package: python3-binoculars
Architecture: all
Section: python
-Depends: gir1.2-hkl-5.0, ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
-Suggests: python-xrayutilities
-Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction - Python3
+Depends: gir1.2-hkl-5.0, ${misc:Depends}, ${python3:Depends}
+Suggests: python3-xrayutilities
+Description: Surface X-ray diffraction 2D detector data reduction - Python3
BINoculars is a tool for data reduction and analysis of large sets of
surface diffraction data that have been acquired with a
two-dimensional X-ray detector. The intensity of each pixel of a
@@ -61,7 +62,8 @@ Package: binoculars-doc
Architecture: all
Section: doc
Depends: ${misc:Depends}, ${sphinxdoc:Depends}
-Description: Data reduction and analysis software for two-dimensional detectors in surface X-ray diffraction - Documentation
+Built-Using: ${sphinxdoc:Built-Using}
+Description: Surface X-ray diffraction 2D detector data reduction - Documentation
BINoculars is a tool for data reduction and analysis of large sets of
surface diffraction data that have been acquired with a
two-dimensional X-ray detector. The intensity of each pixel of a
diff --git a/debian/copyright b/debian/copyright
index ec1ce53..a002380 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -6,6 +6,8 @@ Files: *
Copyright: 2012-2015 European Synchrotron Radiation Facility
Willem Onderwaater <onderwaa@esrf.fr>
Sander Roobol <roobol@physics.leidenuniv.nl>
+ 2015-2018 Synchrotron SOLEIL
+ Frédéric-Emmanuel Picca <picca@synchrotron-soleil.fr>
License: GPL-3.0+
Files: debian/*
diff --git a/debian/py3dist-overrides b/debian/py3dist-overrides
new file mode 100644
index 0000000..2c65b5a
--- /dev/null
+++ b/debian/py3dist-overrides
@@ -0,0 +1 @@
+pyqt5 python3-pyqt5
diff --git a/debian/python-binoculars-doc.docs b/debian/python-binoculars-doc.docs
deleted file mode 100644
index 6d28621..0000000
--- a/debian/python-binoculars-doc.docs
+++ /dev/null
@@ -1 +0,0 @@
-build/html
diff --git a/debian/rules b/debian/rules
index 0921d86..f06e646 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,21 +1,22 @@
#!/usr/bin/make -f
+export DH_VERBOSE=1
export PYBUILD_NAME=binoculars
export PYBUILD_AFTER_INSTALL=rm -rf {destdir}/usr/bin/
%:
- dh $@ --with python2,sphinxdoc --buildsystem=pybuild
+ dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_install:
dh_numpy3
dh_install
# install scripts into binoculars
- python setup.py install_scripts -d debian/binoculars/usr/bin
-
+ python3 setup.py install_scripts -d debian/binoculars/usr/bin
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. http_proxy='127.0.0.1:9' sphinx-build -N -bhtml doc/source build/html # HTML generator
-endif
+ dh_installdocs -p binoculars-doc "build/html"
dh_sphinxdoc -O--buildsystem=pybuild
+endif
diff --git a/setup.py b/setup.py
index ea0b254..35046c0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,5 @@
+# -*- encoding: utf-8 -*-
+
import os
from setuptools import setup, find_packages
@@ -35,7 +37,7 @@ install_requires = ['h5py',
setup(name='binoculars', version='0.0.1',
description=description,
long_description=long_description,
- packages=find_packages(),
+ packages=find_packages(exclude=["*.test", "*.test.*", "test.*", "test"]),
install_requires=install_requires,
scripts=scripts,
author="Willem Onderwaater, Sander Roobol, Frédéric-Emmanuel Picca",
@@ -47,5 +49,5 @@ setup(name='binoculars', version='0.0.1',
'Development Status :: 3 - Alpha',
'Operating System :: POSIX',
'Operating System :: Unix',
- 'Programming Language :: Python :: 2.7 3.6 3.7']
+ 'Programming Language :: Python :: 2.7 3.5 3.6 3.7']
)