summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Gilbert <mgilbert@debian.org>2013-12-29 23:30:10 +0000
committerMichael Gilbert <mgilbert@debian.org>2013-12-29 23:30:10 +0000
commit4a57ebf009b3a059a9d05a31d192d8d9f530db3f (patch)
tree933a3a3ab4e95759c4aaf21201561fd33e8842eb /debian
parentf6e7c3f825f5ddddec21537ee1612a611f4b3504 (diff)
Imported Debian patch 1.3.4-3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control9
-rw-r--r--debian/patches/no-distribute.patch14
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules5
5 files changed, 29 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 61b0252..dfa89fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+blist (1.3.4-3) unstable; urgency=medium
+
+ * Avoid unwanted download when importing distribute_tools (closes: #733425).
+
+ -- Michael Gilbert <mgilbert@debian.org> Sun, 29 Dec 2013 23:30:10 +0000
+
blist (1.3.4-2) unstable; urgency=low
* Team upload
diff --git a/debian/control b/debian/control
index e11bd7e..8cde202 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,14 @@ Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.
Uploaders:
Michael Gilbert <mgilbert@debian.org>
Build-Depends:
- debhelper (>= 9), python-all-dev (>= 2.6.6-3~), python-setuptools
-Standards-Version: 3.9.3
+ debhelper (>= 9),
+ python-setuptools,
+ python-all-dev (>= 2.6.6-3~),
+Standards-Version: 3.9.5
+XS-Python-Version: all
Homepage: http://pypi.python.org/pypi/blist
Vcs-Svn: svn://svn.debian.org/python-modules/packages/blist/trunk
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/blist/trunk/
+Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/blist/trunk
Package: python-blist
Architecture: any
diff --git a/debian/patches/no-distribute.patch b/debian/patches/no-distribute.patch
new file mode 100644
index 0000000..0bdff22
--- /dev/null
+++ b/debian/patches/no-distribute.patch
@@ -0,0 +1,14 @@
+description: avoid unwanted download when importing distribute_setup
+author: Michael Gilbert <mgilbert@debian.org>
+
+--- blist-1.3.4.orig/setup.py 2013-12-29 23:41:57.000000000 +0000
++++ blist-1.3.4/setup.py 2013-12-29 23:45:12.311111154 +0000
+@@ -1,8 +1,6 @@
+ #!/usr/bin/env python
+
+ import sys
+-import distribute_setup
+-distribute_setup.use_setuptools()
+ from setuptools import setup, Extension
+
+ define_macros = []
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..97a7908
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+no-distribute.patch
diff --git a/debian/rules b/debian/rules
index 405be54..9d9e085 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,11 +2,10 @@
export CC=gcc
export LDSHARED=gcc -shared -Wl,-O1 -Wl,-Bsymbolic-functions
+export DH_VERBOSE=1
override_dh_clean:
- echo ${CC}
- rm -f blist.egg-info/PKG-INFO blist.egg-info/SOURCES.txt
- dh_clean
+ dh_clean -- blist.egg-info/PKG-INFO blist.egg-info/SOURCES.txt
%:
dh $@ --with=python2