summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog17
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules2
3 files changed, 22 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index cd1f9a9..61b0252 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
+blist (1.3.4-2) unstable; urgency=low
+
+ * Team upload
+
+ [ Evgeni Golov ]
+ * Non-maintainer upload.
+ * Use dh_python2.
+ * Add python-all-dev to Build-Depends.
+ * Add python:Depends to Depends.
+ * This all closes: #681583
+
+ [ Scott Kitterman ]
+ * Add python-setuptools to Build-Depends
+ * Add missing Vcs-* to Control
+
+ -- Scott Kitterman <scott@kitterman.com> Mon, 23 Jul 2012 00:40:43 -0400
+
blist (1.3.4-1) unstable; urgency=low
* Initial release.
diff --git a/debian/control b/debian/control
index 64f16f0..e11bd7e 100644
--- a/debian/control
+++ b/debian/control
@@ -5,15 +5,18 @@ Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.
Uploaders:
Michael Gilbert <mgilbert@debian.org>
Build-Depends:
- debhelper (>= 9)
+ debhelper (>= 9), python-all-dev (>= 2.6.6-3~), python-setuptools
Standards-Version: 3.9.3
Homepage: http://pypi.python.org/pypi/blist
+Vcs-Svn: svn://svn.debian.org/python-modules/packages/blist/trunk
+Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/blist/trunk/
Package: python-blist
Architecture: any
Depends:
${shlibs:Depends},
${misc:Depends},
+ ${python:Depends}
Description: List-like type for python with better asymptotic performance
This package is a drop-in replacement for the Python list the provides better
performance when modifying large lists. The blist package also provides
diff --git a/debian/rules b/debian/rules
index 53fdee0..405be54 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,4 +9,4 @@ override_dh_clean:
dh_clean
%:
- dh $@
+ dh $@ --with=python2