summaryrefslogtreecommitdiff
path: root/blist.egg-info/PKG-INFO
diff options
context:
space:
mode:
Diffstat (limited to 'blist.egg-info/PKG-INFO')
-rw-r--r--blist.egg-info/PKG-INFO26
1 files changed, 13 insertions, 13 deletions
diff --git a/blist.egg-info/PKG-INFO b/blist.egg-info/PKG-INFO
index a43d00d..2f27158 100644
--- a/blist.egg-info/PKG-INFO
+++ b/blist.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: blist
-Version: 1.3.4
+Version: 1.3.6
Summary: a list-like type with better asymptotic performance and similar performance on small lists
Home-page: http://stutzbachenterprises.com/blist/
Author: Stutzbach Enterprises, LLC
@@ -9,7 +9,7 @@ License: BSD
Description: blist: a list-like type with better performance
===============================================
- The ``blist`` is a drop-in replacement for the Python list the provides
+ The ``blist`` is a drop-in replacement for the Python list that provides
better performance when modifying large lists. The blist package also
provides ``sortedlist``, ``sortedset``, ``weaksortedlist``,
``weaksortedset``, ``sorteddict``, and ``btuple`` types.
@@ -19,7 +19,7 @@ Description: blist: a list-like type with better performance
http://stutzbachenterprises.com/blist-doc/
Python's built-in list is a dynamically-sized array; to insert or
- removal an item from the beginning or middle of the list, it has to
+ remove an item from the beginning or middle of the list, it has to
move most of the list in memory, i.e., O(n) operations. The blist
uses a flexible, hybrid array/tree structure and only needs to move a
small portion of items in memory, specifically using O(log n)
@@ -74,7 +74,7 @@ Description: blist: a list-like type with better performance
- sortedlist
- sortedset
- weaksortedlist
- - weaksorteset
+ - weaksortedset
- sorteddict
- btuple
@@ -130,7 +130,7 @@ Description: blist: a list-like type with better performance
- Constructing a btuple from a blist takes O(1) time.
- Taking a slice of a btuple takes O(n) time, where n is the size of
- the original tuple. The size of the slice does not matter.
+ the original tuple. The size of the slice does not matter.
>>> from blist import blist, btuple
>>> x = blist([0]) # x is a blist with one element
@@ -144,7 +144,7 @@ Description: blist: a list-like type with better performance
distribution, the Python header files are also required. In either
case, just run:
- python setup.py install
+ python setup.py install
If you're running Linux and see a bunch of compilation errors from
GCC, you probably do not have the Python header files installed.
@@ -159,7 +159,7 @@ Description: blist: a list-like type with better performance
If you downloaded the source distribution and wish to run the
associated test suite, you can also run:
- python setup.py test
+ python setup.py test
which will verify the correct installation and functioning of the
package. The tests require Python 2.6 or higher.
@@ -178,13 +178,13 @@ Description: blist: a list-like type with better performance
In addition to the tests include in the source distribution, we
perform the following to add extra rigor to our testing process:
- 1. We use a "fuzzer": a program that randomly generates list
- operations, performs them using both the blist and the built-in
- list, and compares the results.
+ 1. We use a "fuzzer": a program that randomly generates list
+ operations, performs them using both the blist and the built-in
+ list, and compares the results.
- 2. We use a modified Python interpreter where we have replaced the
- array-based built-in list with the blist. Then, we run all of
- the regular Python unit tests.
+ 2. We use a modified Python interpreter where we have replaced the
+ array-based built-in list with the blist. Then, we run all of
+ the regular Python unit tests.
Keywords: blist list b+tree btree fast copy-on-write sparse array sortedlist sorted sortedset weak weaksortedlist weaksortedset sorteddict btuple
Platform: UNKNOWN