summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 3 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 405be54..b82ed19 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,7 @@
#!/usr/bin/make -f
-export CC=gcc
-export LDSHARED=gcc -shared -Wl,-O1 -Wl,-Bsymbolic-functions
-
-override_dh_clean:
- echo ${CC}
- rm -f blist.egg-info/PKG-INFO blist.egg-info/SOURCES.txt
- dh_clean
+export DH_VERBOSE=1
+export PYBUILD_NAME=blist
%:
- dh $@ --with=python2
+ dh $@ --with=python2,python3 --buildsystem=pybuild