summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 12 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 22751ff..5f1ff5d 100755
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,12 @@
#!/usr/bin/env python
+import re
import sys
-import distribute_setup
-distribute_setup.use_setuptools()
+import ez_setup
+ez_setup.use_setuptools()
from setuptools import setup, Extension
+
define_macros = []
import ctypes
@@ -14,19 +16,24 @@ if ctypes.sizeof(ctypes.c_double) == 8:
if iv.contents.value == 0x433fff0102030405:
define_macros.append(('BLIST_FLOAT_RADIX_SORT', 1))
+with open('blist/__init__.py') as f:
+ line = f.readline()
+ match = re.search(r'= *[\'"](.*)[\'"]', line)
+ version = match.group(1)
+
setup(name='blist',
- version='1.3.4',
+ version=version,
description='a list-like type with better asymptotic performance and similar performance on small lists',
author='Stutzbach Enterprises, LLC',
author_email='daniel@stutzbachenterprises.com',
url='http://stutzbachenterprises.com/blist/',
license = "BSD",
keywords = "blist list b+tree btree fast copy-on-write sparse array sortedlist sorted sortedset weak weaksortedlist weaksortedset sorteddict btuple",
- ext_modules=[Extension('_blist', ['_blist.c'],
+ ext_modules=[Extension('blist._blist', ['blist/_blist.c'],
define_macros=define_macros,
)],
+ packages=['blist'],
provides = ['blist'],
- py_modules=['blist', '_sortedlist', '_sorteddict', '_btuple'],
test_suite = "test_blist.test_suite",
zip_safe = False, # zips are broken on cygwin for C extension modules
classifiers = [