summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2022-08-31 10:28:49 -0500
committerArtem Bityutskiy <dedekind1@gmail.com>2022-09-03 20:09:32 +0300
commit1aaa103aef542c38be68dbd9ed8775173db5e206 (patch)
treecbd36388e697c5ec224258982c8812ce8a0641de
parent503419346f20ab0c8c4d5a5b22dca74a5cb990fc (diff)
Add gpg as a dependency
GPG is required to verify signatures Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--.github/workflows/ci.yml3
-rw-r--r--poetry.lock17
-rw-r--r--pyproject.toml1
3 files changed, 17 insertions, 4 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 0c5ca39..7b61782 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -18,6 +18,7 @@ jobs:
python-version: '3.x'
- name: Install dependencies
run: |
+ sudo apt-get install -y libgpgme11-dev
curl -sSL https://install.python-poetry.org | python3 -
poetry install -n
- name: Check code
@@ -40,7 +41,7 @@ jobs:
- name: Install dependencies
run: |
# Installs compression deps
- sudo apt-get install -y pbzip2 pigz lzop liblz4-tool
+ sudo apt-get install -y pbzip2 pigz lzop liblz4-tool libgpgme11-dev
# Installs poetry
curl -sSL https://install.python-poetry.org | python3 -
poetry install -n
diff --git a/poetry.lock b/poetry.lock
index d7b6417..ce2e316 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -40,6 +40,14 @@ optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
[[package]]
+name = "gpg"
+version = "1.10.0"
+description = "Python bindings for GPGME GnuPG cryptography library"
+category = "main"
+optional = false
+python-versions = "*"
+
+[[package]]
name = "mypy-extensions"
version = "0.4.3"
description = "Experimental type system extensions for programs checked with the mypy typechecker."
@@ -72,8 +80,8 @@ optional = false
python-versions = ">=3.7"
[package.extras]
-docs = ["furo (>=2021.7.5b38)", "proselint (>=0.10.2)", "sphinx-autodoc-typehints (>=1.12)", "sphinx (>=4)"]
-test = ["appdirs (==1.4.4)", "pytest-cov (>=2.7)", "pytest-mock (>=3.6)", "pytest (>=6)"]
+docs = ["furo (>=2021.7.5b38)", "proselint (>=0.10.2)", "sphinx (>=4)", "sphinx-autodoc-typehints (>=1.12)"]
+test = ["appdirs (==1.4.4)", "pytest (>=6)", "pytest-cov (>=2.7)", "pytest-mock (>=3.6)"]
[[package]]
name = "six"
@@ -102,7 +110,7 @@ python-versions = ">=3.7"
[metadata]
lock-version = "1.1"
python-versions = "^3.8"
-content-hash = "6e404e5c8ea65f897dbffc07e3737ecbcb7efa4f850116e347b364ee93cafcfe"
+content-hash = "3c149d48fc968146fa2337bed2d5414487fa83cec93d18d803115994e0393f02"
[metadata.files]
black = [
@@ -138,6 +146,9 @@ colorama = [
{file = "colorama-0.4.5-py2.py3-none-any.whl", hash = "sha256:854bf444933e37f5824ae7bfc1e98d5bce2ebe4160d46b5edf346a89358e99da"},
{file = "colorama-0.4.5.tar.gz", hash = "sha256:e6c6b4334fc50988a639d9b98aa429a0b57da6e17b9a44f0451f930b6967b7a4"},
]
+gpg = [
+ {file = "gpg-1.10.0.tar.gz", hash = "sha256:349214a866c84aa548bc35ed14eccd2ec9085b3958d5753a63a19a71a1f523ca"},
+]
mypy-extensions = [
{file = "mypy_extensions-0.4.3-py2.py3-none-any.whl", hash = "sha256:090fedd75945a69ae91ce1303b5824f428daf5a028d2f6ab8a299250a846f15d"},
{file = "mypy_extensions-0.4.3.tar.gz", hash = "sha256:2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"},
diff --git a/pyproject.toml b/pyproject.toml
index 9fa64ce..b211d53 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,6 +9,7 @@ authors = ["Artem Bityutskiy <dedekind1@gmail.com>"]
python = "^3.8"
six = "^1.16.0"
nose = "^1.3.7"
+gpg = "^1.10.0"
[tool.poetry.dev-dependencies]
black = "^22.3.0"